thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Wed Jul 30, 2014 6:09 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sun May 25, 2008 8:10 pm 
Offline

Joined: Sat Feb 19, 2005 2:54 pm
Posts: 34
I have a T61 coming from Lenovo with SUSE Linux preinstalled. I intend to install eComStation 2.0 RC4 on it. My experience in the past is always with installing Linux after having eCS already installed. Has anyone installed eCS on a Thinkpad that already had Linux pre-installed? Does Lenovo include a Linux install disc with these machines? Or will I have to download my own? I've heard that Grub can be installed to the boot partition after the fact so the IBM Boot Manager can boot it. Anyone know if that is true for SUSE?

Mark with a dead T42p, patiently waiting the arrival of a new T61.

_________________
http://www.os2voice.org
http://www.warpstock.org


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 30, 2008 8:33 am 
Offline

Joined: Tue Jan 29, 2008 2:22 pm
Posts: 13
Location: Kingston, ON, CA
do not see any problem installing OS/2 having linux. The questions are:
do you have free space?
is it at the beginning of drive or not?
If you create partition there will the OS/2 boot from it?
And I think if those questions have positive answers you still have to somehow configure the grub to do chainload(0,?) in between those reboots (I believe after you format partition) because as I remember install process does reboot several times.
So I'd create partition for OS/2 from linux, configure grub menu to be able to boot from it and then start OS/2 install.
Bu anyway why to keep the old Suse 10 when Opensuse 11 is "19 days to go". See http://opensuse.org/?
I'll be downloading

:)

_________________
t42, a31p


Top
 Profile  
 
 Post subject:
PostPosted: Fri May 30, 2008 9:14 am 
Offline

Joined: Sat Feb 19, 2005 2:54 pm
Posts: 34
I finally got that straightened out and eCS 2.0 RC4 installed. Took me a bit to figure out how to get Boot Manager and a logical partition on it. SUSE used 3 primaries (/,/SWAP, /HOME) taking up the entire 250GB drive. But I was able to move /SWAP to a logical (using OpenSUSE's LiveCD partitioner) and resize /HOME to provide plenty of room for a big extended partition and now even SUSE boots off of BM. eCS 2.0 RC4 installed even with 3GB of RAM (I had seen elsewhere people reporting problems installing eCS with more than 2GB, but that may have been the 1.2 version).

SMP kernel is working. CPU monitor shows 2 CPUs using normally only about 1% each. With RC4's ACPI/APM (3.05) I am only able to get an hour or so from the 6 Cell battery. It doesn't switch to battery optimization when on battery. OK I checked in the BIOS and changed the SpeedStep setting for battery mode to "Battery Optimized" and now get 2.5 hours on battery. Still need to play a bit more with that.

WSVGA+ display (Intel GMA X3100 GM 965 Mobile Integrated Graphics Controller) works fairly well with SNAP VESA VBE driver at 1680x1050, though there is some brief remnant when dragging windows. SNAP only shows 7616KB of video memory being used. I know nothing about integrated graphics so I have no idea if that can be changed or if it should be for OS/2. At the suggestion of Roderick Klein I installed the Panorama VESA driver and now window drag is much smoother.

Wifi (Intel PRO/Wireless 3945ABG) is working with GenMac from RC4, though on occasion it can't find the router on boot. Not sure if Haven't tried the Intel Gigabit NIC (Wifi (Intel PRO/Wireless 3945ABG) is working, though on occasion it can't find the router on boot. Haven't tried the Intel Gigabit NIC (1049h 82566MM) yet. Does that work with the Intel Pro/1000 driver?

When I tried RC4's Uniaud it trapped. (ICH8 Family) HD Audio Controller. Chuck McKinnis said he has sound working with Paul Smedley's latest Uniaud driver so I tried that. Installing UniAud 1.1.4 RC6 (a complete package ftp://ftp.netlabs.org/pub/uniaud/uniaud114RC6.zip ) first then Paul's updated Uniaud16.sys ( http://download.smedley.info/uniaud16test2.zip ) and UniAud32.sys ( http://download.smedley.info/uniaud32-1.9.4.zip ). Now sound works though the keyboard sound buttons don't work under eCS.

Also with the RC4 Amouse driver the trackpoint works as a 2 button mouse only. I can't get the middle button or scrolling to work. And using comet cursor makes the system act like its a 486, with long pauses and slow typing. I tried the IBM Mouse driver to see if that works better, still no scrolling. On my T42p I could never get Amouse to work right, but the IBM driver worked fine. I miss the middle scrolling with the trackpoint.

A long time ago someone was working on a FireWire driver for OS/2. Anyone have an idea if anything ever came of that? This T61 has a FW port (and an SD/xD/memory stick card slot though eCS doesn't seem to recognize it). No idea what I would use it for other then to try one of the FW drives I have on our Macs. I may try SUSE Linux to see if I can do any video editing with the included Kino app and my Panasonic video camera.

Over all I'm pretty pleased with the T61. Its heavier then the T42p, but it doesn't get any where near as hot as the T42p did. Nice to have the 3 USB ports. I wish I could turn off the touchpad (I hate them) and just use the trackpoint as I did with the T42p. But when I turn it off in the BIOS then SLED won't boot. I need to play with that a bit more. Turning off the touchpad in SLED and then making the BIOS change still doesn't help. :-( I may try another release of Linux, but for now I'll stick with SLED as it came preloaded, so if I have any Thinkpad support issues its there. But did I mention no windoze? ;-)

Mark

_________________
http://www.os2voice.org
http://www.warpstock.org


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group