thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Sun Nov 23, 2014 7:15 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
PostPosted: Tue Dec 30, 2008 11:58 am 
Offline

Joined: Mon Dec 29, 2008 8:37 pm
Posts: 8
Location: Bigler, PA
Hi! I'm new here, but not to computers. I am trying to clone my original ThinkCentre HDD to a new larger drive. Here's the computer particulars:
IBM ThinkCenter A50P (8193A3U) with XP updated including SP3
So the computer is about 4(?) years old. Looking at the HDD with Windows Disk Manager reveals two visible partitions:
IBM_PRELOAD NTFS 34.94G
IBM_SERVICE FAT32 2.29G
I have located the IBM white paper on the IBM Hidden Protected Area where it mentions Partition based recovery vs. HPA based recovery. I assume that since WDM sees both partitions that I have the earlier version that might be easier to clone as opposed to the HPA that is more difficult. Please let me know if my first assumption is correct...
I have tried to simply clone the entire drive with DriveImageXML, with no luck with the hidden partition. Are there any instructions available for this?
My next attempt was to follow the white paper instructions on backing up the protected area. (i.e. press "enter" while booting, then "F11" in the service menu, then "F3" so that FWBACKUP and FWRESTOR can be copied to a floppy.)
Then I power cycle and reboot to XP, insert the floppy, RUN CMD to bring up a command line, and type "a:fwbackup.exe size=640 file=d:\imgset" where d: is an external USB harddrive.
To which I get the error "program too big to fit in memory".
This is absurd, since I just clean booted into a machine with 1.5G of RAM. Pressing 'ctrl-alt-del' and clicking on the Performance tab shows 1.26G of available memory.
Googling the error showed that this error can be generated if the FWBACKUP program is corrupted. So I tried copying the file out of the protected area again with the same result. I also tried starting up FWRESTOR, which started normally...
So what gives? Could the protected image of FWBACKUP be corrupted on my machine? If so, can someone tell me where to download a copy or even email me one?
Or am I on the wrong track?
Thanks in advance for any light you might shed on the subject!


Top
 Profile  
 
 Post subject:
PostPosted: Tue Dec 30, 2008 9:34 pm 
Offline

Joined: Mon Dec 29, 2008 8:37 pm
Posts: 8
Location: Bigler, PA
Update...

After studying some other posts, especially the detailed one by R.G., I came to the realization that the restore area in my A50p is FAT32 and visible by the backup program. I had just used the backup program incorrectly in my previous attempt.

I went back and recloned the 40G drive to the 160G drive with Security set to Normal. I used the Cloning Wizard in Acronis TI11 in Automatic Mode and the process seemed to work fine. It saw both partitions of the source drive and recreated them proportionately larger on the new drive.

I installed the new drive in the boot position and started the A50p up...

Now it takes a loooong time to get to the Bios splash screen and an even loooonger time to get to the XP splash screen. After that, everything seems to work normally...

So what's up with that?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group