thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Fri Oct 31, 2014 11:46 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu May 31, 2012 12:23 am 
Offline

Joined: Mon May 28, 2012 10:35 am
Posts: 16
Location: Helsinki, Finland
Dear forum readers,

I've been a thinkpad user for ages, but registered a few days ago because my old T20's display has started acting up recently. Yes, I know it's an old laptop, but I need it at my garage for various serial port applications. I've tried various USB-RS232-adapters and even a PCMCIA-card, but none has worked as well as the native port on the T20.

The problem is that the colors on the internal display got slightly distorted and the image is panned to show only two thirds of the top left corner (kind of hard to explain...) The panel itself seems to work fine, but maybe 200-400 pixels are left outside the edges on the bottom and right. It is like this when I turn it on (IBM logo shown in bottom right corner, although it should be centered), so I hardly think it's about Windows drivers.

This happens only on the internal display. If I plug in an external VGA-display everything is fine. Therefore I assume that the graphics card itself is OK. Could this be caused by a fractured flex-cable? I'd go ahead and try a new one from eBay, but they seem to be quite expensive considering the value of a T20 these days.

Maybe someone here has seen and probably fixed a similar issue before?


Top
 Profile  
 
PostPosted: Thu May 31, 2012 1:02 am 
Offline
Admin
Admin

Joined: Sun Jun 04, 2006 1:26 am
Posts: 9027
Location: San Jose, CA 95120 USA
Welcome to thinkpads.com!

If you are looking for an easy, no-cost fix, try removing the keyboard and re-seating the LCD cable. It's possible that a bad/loose/dirty connection is causing the problem. If the ribbon cable-to-motherboard connection is solid and you are bold enough to try removing the LCD panel from the lid, you could re-seat the cable where it plugs into the back side of the display. Now's the time to do a complete inspection of the cable to see if there's any visible tears.

If either of those things don't fix the problem, then you're looking at throwing some $$$ (€€€) at the T20. The ribbon (aka, flex) cable may be the source of the problem. It's about the cheapest thing you can replace. It's also possible that the panel itself is bad or the issue exists on the motherboard and there's nothing you can do short of replacing one or the other.

Here's a link to the Hardware Maintenance Manual for the T2x systems: http://download.lenovo.com/ibmdl/pub/pc ... 2p9631.pdf

_________________
Ray Kawakami
[DONOR] X22;X24;X31;X41;X41T;X60;X60s;X61;X61s;X200s;X300;X301;Z60m;Z61t;Z61p;560Z;600;600E;600X;T21;T22;T23;T41,T410;R50;A21p;A22p;A31;A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.


Top
 Profile  
 
PostPosted: Thu Jun 21, 2012 10:05 am 
Offline

Joined: Mon May 28, 2012 10:35 am
Posts: 16
Location: Helsinki, Finland
Hello again,

I finally had the time to bring the laptop home and take it apart. Actually I just had to remove the keyboard to access the ribbon cable connection on the motherboard. I reseated the connector and used a bit of contact cleaner with a topsy and cleaned it with some compressed air. That seemed to fix the problem. Don't know if it was actually badly seated or just dirty... Most important is that it works again. Hopefully for many many years more.

Thank you Ray for your advise.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group