thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Fri Apr 25, 2014 12:08 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Wed Feb 15, 2012 4:07 pm 
Offline

Joined: Wed Feb 15, 2012 3:49 pm
Posts: 10
Location: Ames, Iowa
Hi everyone!

Backlight on my T60 is now dead. LCD is working. Backlight suddenly stopped working, and is off in BIOS as well. Did not have any screen tint.

I reseated LCD connectors, and the graphics card is definitely working.

I don't want to buy an inverter, then a display, and do progressive diagnostics beyond what I've already done. Should I buy a new LCD assembly? Or is there a significant chance (more than 10%) this is a motherboard problem?

Thank you!


Top
 Profile  
 
PostPosted: Wed Feb 15, 2012 4:32 pm 
Offline
RBS10000
RBS10000

Joined: Mon Sep 18, 2006 5:17 am
Posts: 12933
Location: Mt. Cobb, PA USA
Try an external monitor to be sure.
A dead CCFL/backlight will not revive ever.
Depending on your technical level, you could try and replace the CCFL yourself, or buy a replacement LCD.
You MUST buy an IBM/Lenovo original LCD, not a so-called "guaranteed compatible", because they are NOT!
For CCFL swap, see if this helps: viewtopic.php?f=31&t=88991

_________________
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Board Room for:
- LED-mods for the 15" T60/R60/R61
- SATA-mods for any T43/R52 with ATI GPU
- other Services


Top
 Profile  
 
PostPosted: Wed Feb 15, 2012 5:00 pm 
Offline

Joined: Wed Feb 15, 2012 3:49 pm
Posts: 10
Location: Ames, Iowa
RealBlackStuff, thank you!

The graphics card works - I can see a faint correct screen image, though it doesn't illuminate. Pixels activate properly (bios, starting windows, etc.).

I don't want to replace the backlight to find out that it is an inverter problem or a motherboard blown fuse. Also, technically, this is just beyond what I am willing to do - replacing the display itself is quite fine. (15 inch XGA)

So I figured - buy an assembly and shoot several potential trouble spots at once. But if the motherboard could be an issue, maybe I should be looking for a new machine.


Top
 Profile  
 
PostPosted: Wed Feb 15, 2012 5:15 pm 
Offline
RBS10000
RBS10000

Joined: Mon Sep 18, 2006 5:17 am
Posts: 12933
Location: Mt. Cobb, PA USA
Inverters rarely -if ever- die.
And a mobo problem is unlikely since the picture is displayed.
A complete XGA lid for a 15" T60 will set you back anywhere from $80.- upwards.
But try first in the Marketplace forum.

_________________
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Board Room for:
- LED-mods for the 15" T60/R60/R61
- SATA-mods for any T43/R52 with ATI GPU
- other Services


Top
 Profile  
 
PostPosted: Wed Feb 15, 2012 5:20 pm 
Offline

Joined: Wed Feb 15, 2012 3:49 pm
Posts: 10
Location: Ames, Iowa
Thank you, RealBlackStuff! You put my mind at ease.


Top
 Profile  
 
 Post subject: UPDATE
PostPosted: Wed Feb 22, 2012 8:56 pm 
Offline

Joined: Wed Feb 15, 2012 3:49 pm
Posts: 10
Location: Ames, Iowa
UPDATE:

I bought an entire replacement screen assembly (screen, lid, inverter assembled together), installed it and - lo and behold - the problem persists. No change in symptoms.

Backlight on the new lcd assembly does not power on. Display works fine (although it is almost completely black) and I can see pixels activating properly (Bios, starting windows, etc).

Does that mean it is a fuse on the motherboard? I don't have the skills to solder fuses on integrated circuits. Ship to lenovo? How much would that set me back?


Top
 Profile  
 
PostPosted: Wed Feb 22, 2012 9:50 pm 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Sun Feb 25, 2007 11:28 am
Posts: 12035
Location: Albrightsville, Pennsylvania
You'd be better off buying a new laptop than shipping your unit to Lenovo...for $400-500 they would charge to swap a board you can do a lot nowadays...

_________________
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your friendly retired FlexView farmer)

Collecting SSDI: A31p, T42p, T43p

Abused daily: T43pSF, T60, R60F, R500F

For sale: T61, T61p


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 8:45 pm 
Offline

Joined: Wed Feb 15, 2012 3:49 pm
Posts: 10
Location: Ames, Iowa
Oh well. Thank you, Ajkula. This was a really nice board - C2D 1.66 with Intel graphics. I will be looking to buy the exact same computer, then.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group