thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
IBM & lenovo legacy model ThinkPad support files are available on thinkpads.com.
including Hardware Maintenance Manuals, latest or final driver updates and more.
at: thinkpads.com


If you so wish:
Donate using PayPal

It is currently Thu Sep 18, 2014 6:45 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Problem restoring X32
PostPosted: Tue Aug 09, 2011 6:00 am 
Offline
Sophomore Member

Joined: Thu Dec 01, 2005 8:16 pm
Posts: 149
Location: Middlesex, Vermont USA
Model 2672 A43
No recovery partition, no recovery disks

Used an OEM XP disk to get things going, but I have no Ethernet or wireless, thus cannot got to Lenovo for needed updates (or get online at all!)

I have downloaded the drivers (even got the Ethernet from Intel), on my T43, extracted them on to a USB jump drive and can see that they are there and ready to go, when viewed on the T43.

When I put the drive into the x32 the drivers do not show in Windows Explorer; I have also tried burning them to a CD, same result.

In Device Manager I have the Yellow Exclamations next to:
Ethernet Controller
Multimedia Audio Controller
Network Controller
PCI Modem
Unknown device
Video Controllers

Every time I boot it I am interrupted by the "Found New Hardware Wizard" but when I go to the CD or USB drive, I come up empty handed!

I then booted to a Live CD of Ubuntu 10.4 and this quickly finds the wireless card and gets me on line. When in Ubuntu if I browse to the USB jump drive, the drivers are visible but if I try to open them I get a long error message (I assume that is no surpirse, trying to open an XP driver in Ubuntu) that says, in part:

Archive: /media/8658-2213/PROWin32.exe
[/media/8658-2213/PROWin32.exe]
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: /media/8658-2213/PROWin32.exe may be a plain executable, not an archive
zipinfo: cannot find zipfile directory in one of /media/8658-2213/PROWin32.exe or
/media/8658-2213/PROWin32.exe.zip, and cannot find /media/8658-2213/PROWin32.exe.ZIP, period.


An irony as this X32 was a Ubuntu only machine that I was re-loading XP onto in order to make it useful to a sister in need, but now I am the one in need.

Ideas?

_________________
T23, X32 (2672-A43), T43 (2687D4U)


Top
 Profile  
 
PostPosted: Tue Aug 09, 2011 7:16 am 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Sun Aug 07, 2005 5:41 pm
Posts: 2683
Location: Paragould AR USA
Here is something to try...While booted with Ubuntu, copy the ethernet driver to a folder you will be able to locate later on the hard drive. Or, download the file to a location on the hard drive you can find. Then boot into Windows, execute the ethernet exe, which will extract the file to C:/Drivers...then either run the setup script from that folder or point the Windows installer to the folder (I don't remem ber which). That should get the ethernet driver installed so you can use System Update 3.14 to get the other drivers installed.

_________________
Collection = T500 - T400 - T61(14" WSXGA+) - X40 (x2)- T43p- T42p - A31P - A30P - 600E - 770


Top
 Profile  
 
PostPosted: Tue Aug 09, 2011 7:53 am 
Offline
BANNED

Joined: Sat May 21, 2011 2:03 am
Posts: 512
Location: The Lion's Den, New York City, NY
Hi, what mini-PCI wireless card do you have installed in your x32? I would assume it is the Intel WM3B2100? If so, try downloading the Intel Pro/Wireless 2100 driver/utility program for XP Pro from the Intel website here: http://downloadcenter.intel.com/Detail_ ... 2&lang=eng

Use your T43 to download it to a USB flash drive or burn it to CD. Pop it into your X32 and run it. It [should be] a self-extracting/self-executing program and will do the rest. You won't have to hunt around for folders or bother with Windows Found New Hardware wizard. Networks should pop right up. Once you get your wireless network detected you can go online and download the rest of your drivers via Windows update and the Lenovo website. Read this discussion also: viewtopic.php?f=2&t=97276

Best wishes,
Daniel.

_________________
240, 380Z, 390X, 570E, 600x, 701C("The ButterFly"), 770, A20...22,31, G40,41,
R32,40,50,51,52, R60,61, SL410/510,T20...23,30,40...43, T60p UXGA,T61,T400,
TransNote, X20..24,31,40,X41T,X60,61,X60/61T, Z61t, W500

No PM's please. MY email [tigerinspring1@aol.com]


Top
 Profile  
 
PostPosted: Tue Aug 09, 2011 10:29 am 
Offline
Sophomore Member

Joined: Thu Dec 01, 2005 8:16 pm
Posts: 149
Location: Middlesex, Vermont USA
THANK YOU, Neil!!!

That was the suggestion that got me on track, hours later (needing to update Explorer, add 2.0 NET, etc.) I am humming along.

For some reason the x32 would not see the files when I tried to access them either on a USB jump drive or a CD.

_________________
T23, X32 (2672-A43), T43 (2687D4U)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group