thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
IBM & lenovo legacy model ThinkPad support files are available on thinkpads.com.
including Hardware Maintenance Manuals, latest or final driver updates and more.
at: thinkpads.com


If you so wish:
Donate using PayPal

It is currently Thu Dec 18, 2014 3:16 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
PostPosted: Sat Feb 18, 2012 10:11 am 
Offline
Senior Member
Senior Member

Joined: Fri Apr 28, 2006 4:21 pm
Posts: 742
Location: Providence, RI, USA
I replaced the fan in my X61 yesterday, and it works great! Unfortunately I noticed that after the repair the indicator lights at the bottom of my screen no longer light (except for wifi and bluetooth).

What do I need to replace to get them working again?

_________________
X61, T61, T43, T42, X40, IdeaPad S10-3


Top
 Profile  
 
PostPosted: Thu Feb 23, 2012 4:28 pm 
Offline
Moderator
Moderator

Joined: Sun Jan 01, 2006 3:29 pm
Posts: 2901
Location: San Francisco, CA
The symptoms sound like a blown motherboard fuse. Did you have the machine unplugged and battery out before you started?


Top
 Profile  
 
PostPosted: Sun Feb 26, 2012 7:55 pm 
Offline
Senior Member
Senior Member

Joined: Fri Apr 28, 2006 4:21 pm
Posts: 742
Location: Providence, RI, USA
Absolutely, yes. I'm sure because I had to remove the battery to get to one of the keyboard screws...

_________________
X61, T61, T43, T42, X40, IdeaPad S10-3


Top
 Profile  
 
PostPosted: Mon Feb 27, 2012 11:04 pm 
Offline
Moderator
Moderator

Joined: Sun Jan 01, 2006 3:29 pm
Posts: 2901
Location: San Francisco, CA
Beyond that, it is hard to diagnose from 3000 miles away


Top
 Profile  
 
PostPosted: Mon Mar 19, 2012 6:29 pm 
Offline
Junior Member
Junior Member

Joined: Fri Apr 07, 2006 9:04 am
Posts: 353
Location: NJ
The Spirit of X21 wrote:
Absolutely, yes. I'm sure because I had to remove the battery to get to one of the keyboard screws...


Hi Spirit of X21!

It looks like you need to replace the 'LCD inverter card', however are two versions of it: Foxconn and YEC.

You can find more information about it HERE.

Just navigate to 'Parts list' -> 'LCD FRUs' on the left and take a look at the LCD breakdown diagram. You will need part number 11.

I'm willing to bet either or would work just fine. Or you could take the LCD bezel off carefully and then the inverter and take a look at the part number on it.

Hope this helps!

_________________
T61p [8891-CTO]: Intel X9000 (2.8GHz) CPU, 8GB RAM, 128GB OCZ Vertex 2 SSD, 14.1in 1400x1050 (4:3) Modified Symmetrical LCD cover & bezel, nVidia FX 570M, DVDRW, Intel 6300 WiFi, BT, FR, Windows 7, SLIC2.1, Unlocked SATA II middleton BIOS, WLAN Whitelist Modified. Mint Condition.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 10 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group