thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Sat Oct 25, 2014 6:56 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 12 posts ] 
Author Message
 Post subject: 10.6.3 on T60 1951CTO
PostPosted: Sun Apr 18, 2010 11:31 am 
Offline

Joined: Fri Apr 16, 2010 11:36 am
Posts: 8
Location: Tianjin, China
Most of the hardware works, problem it is graphic card, with GMA950 27a2, it only supports the external monitor to display, which keeps the laptop's lcd black, I have read someone have fixed this using dsdt which I do not know how and what the code to change, anyone who know how to do this dsdt?


Top
 Profile  
 
PostPosted: Sun Apr 18, 2010 3:21 pm 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Have a look here (this was for X60 series with an Intel GMA950 ...)

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
PostPosted: Mon Apr 19, 2010 8:43 am 
Offline

Joined: Fri Apr 16, 2010 11:36 am
Posts: 8
Location: Tianjin, China
Thank you. The GMA950 EFI fix the problem.

Other problem I am facing is I put VoodooHDA 0.2.6 under Extra/Extensions and sound is not working, and my wifi is atheros 5424, and it is not working.


Top
 Profile  
 
PostPosted: Tue Apr 20, 2010 8:25 am 
Offline

Joined: Fri Apr 16, 2010 11:36 am
Posts: 8
Location: Tianjin, China
The sound problem is fixed by the Kext Helper, use Kext Helper b7 to install the voodooHDA 0.26 and install VOODOOHDA prefpane.

Only problem is wifi doesn't work, card is Atheros 5424.


Top
 Profile  
 
PostPosted: Tue Apr 20, 2010 8:39 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Have a look here for Atheros Legacy kext ... Edit the plist and modify the id with this one, and put it in /Extra/Extensions/

id:
Code:
<string>pci168c,1014</string>


Repair Permission and rebuild kext cache (... or just simply run pfix !)

Reboot ...

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
PostPosted: Wed Apr 21, 2010 9:45 pm 
Offline

Joined: Fri Apr 16, 2010 11:36 am
Posts: 8
Location: Tianjin, China
It fixed the problem, Just put the AtherosFix.kext under /Extra/Extensions/ and reboot it works. Only touchpad the trackpoint do not work.


Top
 Profile  
 
PostPosted: Thu Apr 22, 2010 3:34 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
afcn007 wrote:
It fixed the problem, Just put the AtherosFix.kext under /Extra/Extensions/ and reboot it works. Only touchpad the trackpoint do not work.

For trackpad and trackpoint use VoodooPS2 linked in the last post here: viewtopic.php?f=32&t=86059

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
PostPosted: Fri Apr 23, 2010 1:03 am 
Offline

Joined: Fri Apr 16, 2010 11:36 am
Posts: 8
Location: Tianjin, China
That fixed the problem, but I need to use kext helper to install the voodoops2 and ultranav drv.

Only right now the sleep does not work. Seems it relates to the voodoops2.


Top
 Profile  
 
PostPosted: Fri Apr 23, 2010 3:11 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
afcn007 wrote:
That fixed the problem, but I need to use kext helper to install the voodoops2 and ultranav drv.

Only right now the sleep does not work. Seems it relates to the voodoops2.


Download pfix and run in once, it will generate proper kext caches for you.

What is your sleep problem? If you cannon wake up, than it's audio related problem, most probably VoodooHDA related. If your screen is not shutting off, that it's video driver problem. VoodooPS2 cannot break sleep.

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
PostPosted: Fri Apr 23, 2010 3:40 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Silencer wrote:
VoodooPS2 cannot break sleep.


Actually it does on my X60t ... and so does VoodooHDA ... But sleep is a very tricky issue : I guess every config has its own sleep issues depending on the hardware and the software solution used to make it work ...

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
PostPosted: Thu Jan 27, 2011 9:16 am 
Offline

Joined: Fri Apr 16, 2010 11:36 am
Posts: 8
Location: Tianjin, China
I have upgrade from 10.6.4 to 10.6.6, I found when reboot, it stop at the Atheros5424 driver, and a cpu panic, if I disable the wifi in bios, I can boot successfully with 10.6.6 all works well except the wifi, any ideas?


Top
 Profile  
 
PostPosted: Sun Feb 06, 2011 4:44 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
afcn007 wrote:
I have upgrade from 10.6.4 to 10.6.6, I found when reboot, it stop at the Atheros5424 driver, and a cpu panic, if I disable the wifi in bios, I can boot successfully with 10.6.6 all works well except the wifi, any ideas?


Wifi support (Atheros) changed during 10.6.5 update. Check here to see what we did to recover wifi : viewtopic.php?f=32&t=86621&start=194

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group