thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Wed Oct 22, 2014 8:51 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 325 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11  Next
Author Message
PostPosted: Mon Mar 05, 2012 1:34 pm 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
sleepyTP wrote:
This is an awesome thread...Got my old X61 going with 10.7.3 and it is great!
The tutorial on the first page worked perfectly. The only outstanding issue that I have is getting the tablet/stylus to work. I've installed the tablet enabler kext. I can see it loaded in system profiler. Tablet magic is also installed and accessible in system preferences. When I load tabletmagic serial0 is slected and and all seems right but I get no response from the stylus. Is there something that I am missing? Does the serial port need to be set to a specific interrupt in the bios?
Thanks for any help!

That's great, sleepyTP! Congrats :)

To make Wacom Tablet portion work you need to make sure about three things:
1) DSDT provided in my first post contains a device named WACF008. This is a multitouch/tablet device
2) /System/Library/Extensions/Apple16X50Serial.kext/Contens/PlugIns/Apple16X50ACPI.kext/Contents/Info.plist must contain a link to that device
Search for the "ACPI 16X50 Serial Port" section and find IONameMatch dictionary key. Its value must be WACF008
(Don't forget to rebuild kext cache and restart after kext changes)
3) You need TabletEnabler running and TabletMagic configured - go to System Preferences/TabletMagic and
choose the right serial port for your tablet (it should run with "Automatic" settings but you may need to change it specifically to "serial0")

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Mon Mar 05, 2012 6:11 pm 
Offline

Joined: Mon Jun 28, 2010 12:28 am
Posts: 4
Location: Cambridge, MA
Hi all. This thread has been invaluable to get my X61 Tablet going. The combo of 1400x1050 and Lion is unbeatable! I have the Wacom going and the fingerprint reader as well. Getting iStat2 going was a bit tricky, but it works provided you install the kexts correctly.

I have two outstanding issues:

1.) No sleep. Even after following examples in this thread of installing SleepEnabler, turning off hibernation, turning off motion sensors and setting the PCI IRQ's to auto, the machine still reboots when it tries to wake up. I updated the firmware on my SSD too, an OCZ Vertex 2. I'm using the Middleton BIOS as well. I'm out of ideas here.

2.) No Screen Brightness. (Half lit screen syndrome on anything other 100%) I tried installing other FrameBuffer kexts, but they kernel panicked. It was so bad, I had to start from scratch, not even putting back the original kext worked. Does anyone have a newer FB kext, or is this a DSDT hack?

I am basically using the bundle of kexts and dsdt.aml from original post, with a few tweaks. The other minor thing is that it doesn't seem to build any kind of kext cache for faster booting, but that is minor.

Thanks to all who have shared their experiences so far. It's a great platform to hackintosh on, I also have 10.6 running on a X61s and that is awesome as well. The tablet is a bit heavier but the screen is killer, basically a 17" MBP in a 12" screen!


Top
 Profile  
 
PostPosted: Tue Mar 06, 2012 6:22 am 
Offline

Joined: Thu Jan 29, 2009 11:00 am
Posts: 18
Location: Darmstadt, Germany
Hi there,
my X61t is up and running Lion really well. Much better than SL. I will up a next package for iStat2, which is better than the one from first post. There are more options like AirPort, CPU A / B, HeatSink … . Will up it later.

For the upcoming 10.8 (Mountain Lion) my X61 will not work, cause it will boot in 64 bit Kernel with 64 bit extensions only. So we will need a 64 bit driver for AppleHDA + X3100FB. Please, have a look at those links, maybe they will work in 64 bit AND QE/OpenGL.

Maybe sleep is not working with the 10.6.2 Version of X3100FB.kext

http://www.osx86.net/downloads.php?do=file&id=1148&page=2

http://translate.google.com/translate?sl=auto&tl=en&js=n&prev=_t&hl=de&ie=UTF-8&layout=2&eotf=1&u=http%3A%2F%2Fwww.insanelymac.com%2Fforum%2Findex.php%3Fshowtopic%3D263722%26pid%3D1754009%26mode%3Dthreaded%26start%3D%23entry1754009

See you - A L E X

_________________
_________________
Lenovo X61t
Intel CoreDuo 1,6 GHz (L7500)
4 GB / 80GBSSD / GMA965 / FW 400 / SD Card
Bluetooth / Wifi AR5BXB6 / Tablet
MacOSX 10.7.3 (DSDT patch)


Top
 Profile  
 
PostPosted: Tue Mar 06, 2012 2:50 pm 
Offline

Joined: Tue Dec 27, 2011 10:02 am
Posts: 25
Location: Vilnius, Lithuania
ttikeda wrote:

2.) No Screen Brightness. (Half lit screen syndrome on anything other 100%) I tried installing other FrameBuffer kexts, but they kernel panicked. It was so bad, I had to start from scratch, not even putting back the original kext worked. Does anyone have a newer FB kext, or is this a DSDT hack?


Install kexts from this link http://www.mediafire.com/download.php?vz91zy2faukok95 you will have your brightness control and nice even backlit.

_________________
X61T 7767-96U 4GB ram. Lion 10.7.0 OS


Top
 Profile  
 
PostPosted: Tue Mar 06, 2012 4:51 pm 
Offline

Joined: Thu Jan 29, 2009 11:00 am
Posts: 18
Location: Darmstadt, Germany
http://www.mediafire.com/?kg48oc84gyjcs5c

My kexts for getting airport temperature.

_________________
_________________
Lenovo X61t
Intel CoreDuo 1,6 GHz (L7500)
4 GB / 80GBSSD / GMA965 / FW 400 / SD Card
Bluetooth / Wifi AR5BXB6 / Tablet
MacOSX 10.7.3 (DSDT patch)


Top
 Profile  
 
PostPosted: Tue Mar 06, 2012 8:47 pm 
Offline

Joined: Mon Jun 28, 2010 12:28 am
Posts: 4
Location: Cambridge, MA
Pirmas, thank you very much. It solved the brightness problem! As it turned out I only needed the two x3100 kexts, the DSDT.aml didn't make a difference. (To be honest, Anastasius's original one works better, it enabled the tablet for me.)

Grandflash, I tried your sensor kexts, they do read more sensors but decided to stick with the original ones in Anastasius's post, because it reads Fan Speed.

I will likely bundle up everything I've used, which is basically a greatest hits of this whole thread. Most if derives from the original post, but I've modified a few things along the way, and cleared up some annoying glitches.

My Thinkpad X61 Tablet is a type 7762-AS1 with the 1400x1050 screen. Everything works except: Sleep, SpeedStep, possibly c-states, and my FireWire. (It says GUID = 00000000 like crazy in Console, so I killed it in BIOS.

My bundle will have everything I know of, including the Middleton BIOS, MultiBeast, KextBeast, TabletMagic, settings for the tablet, keyboard remapper for the annoying mis-mapped `~ key, iStat2 with altered FakeSMC kext, Fingerprint Reader utility, SmartScroll, MenuCracker, and instructions how to enable TRIM support for SSD drives. Of course, an Extra folder with DSDT.aml, org.chameleon.Boot.plist, smbios.plist and the complete set of kexts you'll need. Like others, I recommend buying a Atheros AR5008 wifi card, I was pleasantly surprised my X61T had three antennae wires for it.

On my X61s machine, I have drivers for the Verizon WWAN card if anyone is interested. (It's running 10.6)


Top
 Profile  
 
PostPosted: Wed Mar 07, 2012 1:35 am 
Offline

Joined: Mon Jun 28, 2010 12:28 am
Posts: 4
Location: Cambridge, MA
Ok, I just wrote a massive soup to nuts on my blog. It includes all the help I got from here, I should edit my post to thank you guys, but I gotta sleep! Check it out, I will take your edits and repost it here later. http://tatsuikeda.tumblr.com/


Top
 Profile  
 
PostPosted: Wed Mar 07, 2012 1:48 pm 
Offline

Joined: Mon Jun 28, 2010 12:28 am
Posts: 4
Location: Cambridge, MA
I'm still working on Sleep. (I'm afraid I'll never get FireWire going and my hunch is it has something to do with the Middleton BIOS.) Here is what is going on. Any tips greatly appreciated.

I have a X61 Tablet and a OCZ Vertex 2. I have installed the "Middleton" BIOS which enables SATA-2. I'm running Lion 10.7.3.

I used MultiBeast 4.2.1 to get it going and a whole bunch of hacks including a custom DSDT, smbios.plist and org.Chameleon plist, and about 18 kexts.

I cannot get this machine to not reboot when waking from sleep. It goes to sleep fine, but when it is awoken, the hard drive icon flashes and then after 1 second, it reboots.

What I have tried:
The latest SleepEnabler from
the google code project page
Booting in Windows and turning off Active Protection System
In the BIOS: Turning on Extended Memory Tests, Auto for PCI IRQs
Enabling TRIM
Updating the OCZ Vertex 2's firmware to version 1.35
Disabling Sudden Motion Sensor in Terminal (sudo pmset -a sms 0)
Disabling Hibernation Mode in Terminal (sudo pmset -a hibernatemode 0)
Disabling Encrypted Virtual Memory (sudo defaults write /Library/Preferences/com.apple.virtualMemory DisableEncryptedSwap -boolean yes)
Turning on and off Hard Disk sleep in Energy Saver (tried both)
The RIP3Lion Applescript

If anyone has any other suggestions that would be appreciated. I was thinking to clone my drive to a normal 7200 rpm hard drive to see if it's the same next, but that would take a really long time.


Top
 Profile  
 
PostPosted: Wed Mar 07, 2012 3:19 pm 
Offline

Joined: Mon Mar 05, 2012 11:53 am
Posts: 7
Does it make a difference with the tablet In my x61 is a 1024x768 unit? I assume that WACF008 is the higher resolution screen and WACF004 is the low resolution one. No matter what I try I can not seem to get the tablet to work. Tablet magic sees it, but no input from the stylus is accepted. Please help! Other than this one issue all is working well!

I've done what was suggested by Anastasius but it still does not seem to work.

Does the DSDT need to be updated to accept WACF004?


Top
 Profile  
 
PostPosted: Mon Mar 19, 2012 8:26 am 
Offline

Joined: Mon Mar 14, 2011 8:15 am
Posts: 4
Location: Ft.Lauderdale, FL
Everyone is concentrated on the DSDT and smbios files etc.etc.
.....and we have forgotten that in light of all those things, which are good...just a simple
old fashion kext mod and kext search will fix all these problems.

and I say because I have an X61 T 7762-B6U that EVERYTHING WORKS.
And the only mod to it was a flash of a modded bios to allow sata2 speeds and remove the whitelist,
cause I installed DEll 1390 wifi card from ebay for 9 bucks. (it made life easier).

Tablet digitizer works
fingerprint works
bluetooth works
ps2 and all USB works
audio works
cardbus works
SDReader works
SLEEPMODE works
APP STOE works
FACETIME works
SKPYE Works
MS Office WORKS.
720 and 1080i videos works.

So there you have it.. my 2 cents great job on the files.

_________________
TC1100: 2G, 32G SSD Windows 7
LE1400: 2G, 32G SSD Windows 7
LE1600: 2.5G 40G HD Mac OSX 10.5.8
Fujitsi 4020 2.5G 40G Windows 7
Lenovo X60 Tablet 160G Mac OSX 10.6.6

New. Lenovo X61 Tablet 120G SSD OSX 10.7.3


Top
 Profile  
 
PostPosted: Mon Mar 19, 2012 8:32 am 
Offline

Joined: Mon Mar 14, 2011 8:15 am
Posts: 4
Location: Ft.Lauderdale, FL
Find the 10.7.3 sleep enabler KEXT.
Install it here extra/extentions

your done.



ttikeda wrote:
I'm still working on Sleep. (I'm afraid I'll never get FireWire going and my hunch is it has something to do with the Middleton BIOS.) Here is what is going on. Any tips greatly appreciated.

I have a X61 Tablet and a OCZ Vertex 2. I have installed the "Middleton" BIOS which enables SATA-2. I'm running Lion 10.7.3.

I used MultiBeast 4.2.1 to get it going and a whole bunch of hacks including a custom DSDT, smbios.plist and org.Chameleon plist, and about 18 kexts.

I cannot get this machine to not reboot when waking from sleep. It goes to sleep fine, but when it is awoken, the hard drive icon flashes and then after 1 second, it reboots.

What I have tried:
The latest SleepEnabler from
the google code project page
Booting in Windows and turning off Active Protection System
In the BIOS: Turning on Extended Memory Tests, Auto for PCI IRQs
Enabling TRIM
Updating the OCZ Vertex 2's firmware to version 1.35
Disabling Sudden Motion Sensor in Terminal (sudo pmset -a sms 0)
Disabling Hibernation Mode in Terminal (sudo pmset -a hibernatemode 0)
Disabling Encrypted Virtual Memory (sudo defaults write /Library/Preferences/com.apple.virtualMemory DisableEncryptedSwap -boolean yes)
Turning on and off Hard Disk sleep in Energy Saver (tried both)
The RIP3Lion Applescript

If anyone has any other suggestions that would be appreciated. I was thinking to clone my drive to a normal 7200 rpm hard drive to see if it's the same next, but that would take a really long time.

_________________
TC1100: 2G, 32G SSD Windows 7
LE1400: 2G, 32G SSD Windows 7
LE1600: 2.5G 40G HD Mac OSX 10.5.8
Fujitsi 4020 2.5G 40G Windows 7
Lenovo X60 Tablet 160G Mac OSX 10.6.6

New. Lenovo X61 Tablet 120G SSD OSX 10.7.3


Top
 Profile  
 
PostPosted: Tue Mar 20, 2012 2:05 am 
Offline
ThinkPadder
ThinkPadder

Joined: Sat Apr 22, 2006 4:26 pm
Posts: 1515
Location: TX, USA & Bombay, India
norcimo wrote:
Everyone is concentrated on the DSDT and smbios files etc.etc.
.....and we have forgotten that in light of all those things, which are good...just a simple
old fashion kext mod and kext search will fix all these problems.

and I say because I have an X61 T 7762-B6U that EVERYTHING WORKS.
And the only mod to it was a flash of a modded bios to allow sata2 speeds and remove the whitelist,
cause I installed DEll 1390 wifi card from ebay for 9 bucks. (it made life easier).

Tablet digitizer works
fingerprint works
bluetooth works
ps2 and all USB works
audio works
cardbus works
SDReader works
SLEEPMODE works
APP STOE works
FACETIME works
SKPYE Works
MS Office WORKS.
720 and 1080i videos works.

So there you have it.. my 2 cents great job on the files.


Can you please post a How To guide for someone starting from SCRATCH! ? Please. I have done the Middleton BIOS, but would appreciate your guided steps? - Maybe the Mod/Original poster can add & update your guide into the first post as well.

_________________
T61 8892-02U: 14.1"SXGA+/2.2C2D/4G/XP|Adv Mini Dock|30" Gateway XHD3000 WQXGA via Dual-link DVI
X61T 7767-96U: 12.1"SXGA+/1.6C2D/3G/Vista|Ultrabase
W510 4319-2PU: 15.6"FHD/i7-720QM/4G/Win7Pro64 (for dad)
T43 1875-DLU: 14.1"XGA/1.7PM-740/1G/XP (Old)


Top
 Profile  
 
PostPosted: Tue Mar 20, 2012 3:54 am 
Offline

Joined: Tue Dec 27, 2011 10:02 am
Posts: 25
Location: Vilnius, Lithuania
norcimo wrote:
Everyone is concentrated on the DSDT and smbios files etc.etc.
.....and we have forgotten that in light of all those things, which are good...just a simple
old fashion kext mod and kext search will fix all these problems.

and I say because I have an X61 T 7762-B6U that EVERYTHING WORKS.
And the only mod to it was a flash of a modded bios to allow sata2 speeds and remove the whitelist,
cause I installed DEll 1390 wifi card from ebay for 9 bucks. (it made life easier).

Tablet digitizer works
fingerprint works
bluetooth works
ps2 and all USB works
audio works
cardbus works
SDReader works
SLEEPMODE works
APP STOE works
FACETIME works
SKPYE Works
MS Office WORKS.
720 and 1080i videos works.

So there you have it.. my 2 cents great job on the files.


Can you share your kexts? thanks

_________________
X61T 7767-96U 4GB ram. Lion 10.7.0 OS


Top
 Profile  
 
PostPosted: Fri Mar 23, 2012 10:13 pm 
Offline
Sophomore Member

Joined: Mon Jan 10, 2011 10:37 am
Posts: 172
Location: New York, NY
Quote:
cardbus works


Could you share the kexts to make cardbus working? I really want to test it on my laptop.
I have PCMCIA eSATA, Wifi, USB 3 cards, all works under leopard, I hope I can use them under Lion.
Really appreciated.

_________________
X61 T8300 4GB Lion 10.7.3
T61 T9300 4GB Mavericks 10.9.3
T61 T8300 4GB Mavericks 10.9.3
T61 T7500 4GB Mountain Lion 10.8.5
T61p T7700 4GB Mavericks 10.9.1
T61p T7500 8GB Mavericks 10.9.3
X201 i5-540M 8GB Mavericks 10.9.3
T410 i5-560M 8GB Mavericks 10.9.3
T420 i5-2520M 8GB Mavericks 10.9.3


Top
 Profile  
 
PostPosted: Sat Mar 24, 2012 11:50 pm 
Offline
Freshman Member

Joined: Tue Oct 12, 2010 8:02 am
Posts: 78
Location: Berlin, Germany
Great Gatsby wrote:
Which is a real pity, because IMHO FileVault 2 is the killer feature of Lion (all the others are rather not features I've been deeply missing in Snow Leopard so far :|).


Anastasius wrote:
Yeah, I'm itching to use it and still not found the way as well :(


Another update FYI: The person who had requested FileVault 2 support for Chameleon on the project's bug tracker in February has now published her first findings on the topic:

Hannah Howard wrote:
Fyi, i've been looking into it, and it needs more than just a recovery partition. the person who seems to be taking a shot at it somewhat is someone named RevoGirl - revogirl.wordpress.com.

the problem is the entire unlocking process happens in EFI, before the kernel is loaded. basically, it's whatever logic resides in the boot.efi that sits on the recover hd (in System/Library/Coreservices). that file loads the login interface that lets you type in your password, using images which sit in so called .efires files which reside in "Recovery HD/com.apple.boot.S/usr/standalone/EFILoginUI/".

it's not enough simply to install a chameleon boot loader on the recovery hd-- because currently chameleon can't perform the same logic that the boot.efi on the Recovery HD does to perform the unlock process. you'd have to add functionality to chameleon to completely emulate this process. you'd need to:
1. perform the login by loading the .efires files to create the login UI
2. actually use the password to decrypt the CoreStorage volume where the actual data lives.

sounds kind of complicated and overwhelming, at least until apple releases some data about the CoreStorage format.


Top
 Profile  
 
PostPosted: Tue Mar 27, 2012 5:05 pm 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
Great Gatsby wrote:

Another update FYI: The person who had requested FileVault 2 support for Chameleon on the project's bug tracker in February has now published her first findings on the topic:


Yeah, I see it's quite a complex task :) I hope someone finally makes it until the end of the year at least :)

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Fri Apr 06, 2012 7:57 pm 
Offline

Joined: Thu Sep 10, 2009 12:12 pm
Posts: 14
Location: New York City, NY
Anastasius,

Ive been reading your posts for the IBM x61t and how you achieved OSX on it. I am so close but need help with the post up. I was trying to mix in post and pre instructions based on your guide.

I basically got iAtk0s L2 Lion to boot up and install no problem with the selection of what was given to me. It installs fine and boots into and gets to the desktop. This is where it gets rough.

These features are missing from after the installation:
No Trackpad or Keyboard features (have to use a USB mouse and keyboard for input)
No sound (used Voodoo...but made a screeching sound when booting into OSX. Have to plug into audio only to hear the screeching sound and audio of me using the mic)
SD card not reading
Graphic card reads x3100...but computer lags and freezes while in operation. Have to keep restarting Finder


Can you please just let me know what Kexts are needed for me to get the stuff mentioned above to work. I tried several times to do various things but would get a kernel panic when I did.
If possible, how do I install DSDT you suppled during post installation? Is it even necessary?


Top
 Profile  
 
PostPosted: Sat Apr 07, 2012 11:29 am 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
Joeminati wrote:
Anastasius,

Ive been reading your posts for the IBM x61t and how you achieved OSX on it. I am so close but need help with the post up. I was trying to mix in post and pre instructions based on your guide.

I basically got iAtk0s L2 Lion to boot up and install no problem with the selection of what was given to me. It installs fine and boots into and gets to the desktop. This is where it gets rough.

These features are missing from after the installation:
No Trackpad or Keyboard features (have to use a USB mouse and keyboard for input)
No sound (used Voodoo...but made a screeching sound when booting into OSX. Have to plug into audio only to hear the screeching sound and audio of me using the mic)
SD card not reading
Graphic card reads x3100...but computer lags and freezes while in operation. Have to keep restarting Finder


Can you please just let me know what Kexts are needed for me to get the stuff mentioned above to work. I tried several times to do various things but would get a kernel panic when I did.
If possible, how do I install DSDT you suppled during post installation? Is it even necessary?

Joeminati,
Of course you need a DSDT - you need to place it inside /Extra folder. Actually you need the whole contents of /Extra folder exactly as I provided it for everything to work. The /Extra folder must be put to the root of your hard drive. This folder is used by Chameleon and other projects based on it. So you need a Chameleon to be installed (the latest version). Or any other boot loader based on Chameleon. Note that these steps are also necessary for iCloud and App Store to work fine.
For Trackpad & Keyboard you need VoodooPS2Controller.kext (with VoodooPS2Keyboard.kext and VoodooPS2Mouse.kext INSIDE of it).
For sound I use modified AppleHDA.kext which is provided in my package. Modified AppleHDA won't work without DSDT. And to install it delete your VoodooHDA and previous version of AppleHDA. For X3100 to work you need to replace AppleIntelX3100***.kext files provided in my package.
SD cards needs a special kext which is also provided in this thread,

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Sat Apr 07, 2012 11:52 am 
Offline

Joined: Thu Sep 10, 2009 12:12 pm
Posts: 14
Location: New York City, NY
In what order do you recommend that I install these? First Replace the Extra folder and then reboot and then kext? Or Kext and then Extra and reboot?


Sorry I keep asking questions. I just hate the slow install time on the slow CD drive on the Ultrabay.


Top
 Profile  
 
PostPosted: Sat Apr 07, 2012 12:25 pm 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
Joeminati wrote:
In what order do you recommend that I install these? First Replace the Extra folder and then reboot and then kext? Or Kext and then Extra and reboot?
Sorry I keep asking questions. I just hate the slow install time on the slow CD drive on the Ultrabay.

It doesn't actually matter: you can replace Extra folder, then replace kexts without reboot. Don't forget to
1) set the right permissions on new kexts in /System/Library/Extensions
chmod -R 755 /System/Library/Extensions/*
chown -R 0:0 /System/Library/Extensions/*
2) delete everything inside /System/Library/Caches/com.apple.kext.caches/
3) Update caches:
kextcache -system-prelinked-kernel
kextcache -system-caches

Then reboot

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Mon Apr 09, 2012 6:48 pm 
Offline

Joined: Thu Sep 10, 2009 12:12 pm
Posts: 14
Location: New York City, NY
Can you provide me a link to your files?

I do not see the PS2voodoo kexts. Just the x61t kexts which i have ready when i replaced the whole Extra folder in the root of the HD.

I also took the DSDT from the X61T folder and placed it in the Extra folder as instructed.


Top
 Profile  
 
PostPosted: Mon Apr 09, 2012 7:23 pm 
Offline

Joined: Thu Sep 10, 2009 12:12 pm
Posts: 14
Location: New York City, NY
*****Expletives removed by Moderator*****... Another kernel panic.

You might have to just explain to me like I am an idiot. :\


Top
 Profile  
 
PostPosted: Tue Apr 10, 2012 12:13 pm 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
Joeminati wrote:
*****Expletives removed by Moderator*****... Another kernel panic.

You might have to just explain to me like I am an idiot. :\

You just need a little more time to get comfortable with all that stuff ;)

You need to place these files: http://www.mediafire.com/?i09ptrkjar6m23g
into /System/Library/Extensions
(don't forget to fix the permissions with the instructions above and don't forget to backup your original kexts!!)

And these files: http://www.mediafire.com/?j7zln8r9lr57un9
Into /Extra folder

I also recommend you installing Chameleon r1649+ as my package uses its features

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Fri Apr 13, 2012 9:39 pm 
Offline

Joined: Thu Sep 10, 2009 12:12 pm
Posts: 14
Location: New York City, NY
I am not the best at where to code.

Can I just run Kext helper or an app for the kexts and drivers will automatically update? :wink:


Top
 Profile  
 
PostPosted: Sat Apr 14, 2012 5:53 pm 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
Joeminati wrote:
I am not the best at where to code.

Can I just run Kext helper or an app for the kexts and drivers will automatically update? :wink:

You don't need to code - just copy files in places and run the commands in Terminal.

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Sun Apr 15, 2012 4:15 pm 
Offline
Sophomore Member

Joined: Fri Feb 29, 2008 2:16 am
Posts: 140
Location: Moscow, Russia
I updated my original manual in the first post of this thread to v1.2.
What's new:

1) Bluetooth now works for me out of the box after I did a clean Lion 10.7 install and updated with 10.7.2. Apple Magic Mouse and Bluetooth Keyboard work too.
2) I installed the following SDHC drivers and have SD Card working: http://www.mediafire.com/?u6vl411n3u674fb
3) I finally got rid of Open GL freezes on X3100 and improved overall graphics speed and stability using the following procedures and additional SSDT tables with the latest Chameleon:
a) Booted into Windows
b) Installed EVEREST (now it's called AIDA64)
c) Right-clicked on the software and chose "Save DSDT", saved it to "SSDT.aml" (note that the file name is SSDT.aml, it's the correct name)
d) Clicked on "Save Table" and clicked one by one all items with "SSDT" in name and saved them as "SSDT-X.aml" where X is the order number. I had 10 files: SSDT-1.aml to SSDT-10.aml
e) Saved those files into /Extra folder
f) Set DropSSDT=Yes in org.chameleon.boot.plist

You can download my tables here: http://www.mediafire.com/?jkqjhk955babcy4 but note that your own tables may differ if you have a different hardware. So please follow the instructions above to extract your specific tables.

After these steps I have a faster Quartz animations and faster Flash with no freezes or problems.

_________________
Mac OS X 10.6.7, 10.6.8 and 10.7.2 Lion on X61 7767 tablet.


Top
 Profile  
 
PostPosted: Mon Apr 16, 2012 9:41 am 
Offline

Joined: Thu Nov 10, 2011 11:56 am
Posts: 26
Location: Valparaíso, Chile (traveling through SA)
Nice post Anastasius! Thanks!

Your SSDT files seem to be working fine for me, but once I get a windows installation working, I'll upload mine as well.

By the way, Is there any news on X3100 kexts working in 64bits? I understand that this is the only one left to have a fully working 64 bit system, right? (I am thinking on the future and Mountan Lion). Does anyone know if we can collaborate in any project?(donation/documentation/hardware is what I could do, as I never programmed a driver).

_________________
Thinkpad X61 Tablet 7763-CTO 4GB RAM
Processor: 1.79 Ghz Intel C2D
Graphics: Intel GMA 965 (0x8086, 0x2a02), 1400x1050
WI-FI: Apple Airport Extreme (0x168C, 0x0024 - Atheros 5416 4.0)
Disk: SAMSUNG 640GB HM641JI GPT
OS:Mac OS X Lion 10.7.3 (11D46), Chameleon r1664, tri-boot Ubuntu+W7


Top
 Profile  
 
PostPosted: Tue Apr 17, 2012 3:02 am 
Offline

Joined: Thu Nov 10, 2011 11:56 am
Posts: 26
Location: Valparaíso, Chile (traveling through SA)
Well, I was too fast with my joy. It keeps freezing and not working that fast... I have to install windows (I formatted my drive) and see if with my own SSDTs it changes.

_________________
Thinkpad X61 Tablet 7763-CTO 4GB RAM
Processor: 1.79 Ghz Intel C2D
Graphics: Intel GMA 965 (0x8086, 0x2a02), 1400x1050
WI-FI: Apple Airport Extreme (0x168C, 0x0024 - Atheros 5416 4.0)
Disk: SAMSUNG 640GB HM641JI GPT
OS:Mac OS X Lion 10.7.3 (11D46), Chameleon r1664, tri-boot Ubuntu+W7


Top
 Profile  
 
PostPosted: Wed Apr 18, 2012 3:06 pm 
Offline

Joined: Wed Apr 18, 2012 1:57 pm
Posts: 1
Location: Omaha, NE
My Thinkpad has the appropriate DSDT entry, and the entry is identified in the Apple16x50APCI.Plist as WACF0008, and I have Tablet Magic working, which sees a tablet in 10.7.3, but gets no input and serial() doesn't show up. The tablet works as advertised under Ubuntu Linux and Windows, so it has to be something else in the DSDT. Any ideas? Why unable to get serial()?

Mark


Top
 Profile  
 
PostPosted: Fri Apr 20, 2012 8:35 pm 
Offline

Joined: Fri Apr 20, 2012 8:28 pm
Posts: 1
Location: Sydney, NSW, Australia
Hey folks, first time on this forum bear with me. I've been trying to get Lion installed on my X61 tablet using UniBeast and this guide: http://tonymacx86.blogspot.com.au/2011/ ... using.html which jzhang said would probably be the best way. I haven't attempted to hackintosh Lion before (attempted SL but my hardware was incompatiable). I want to try it out on my x61 which SHOULD work before I go out and buy the parts for a desktop.

Anyway, long story short, following the guide, everything is good up until the part where I have to boot off the drive, I get the apple logo, it spins around for a bit and then kernel panics. I've tried various bootflags including safe mode, single user, verbose, GraphicsEnabler=No and quite a few combinations in between.

I get the following in verbose mode: http://dl.dropbox.com/u/16006838/Photo% ... -12-AM.jpg

I can't seem to find anything online so hoping someone can help me out here.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 325 posts ]  Go to page Previous  1 ... 5, 6, 7, 8, 9, 10, 11  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group