thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Wed Aug 20, 2014 7:24 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 15 posts ] 
Author Message
 Post subject: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 7:15 am 
Offline
Freshman Member

Joined: Wed Nov 21, 2007 11:10 am
Posts: 89
Location: Karlsruhe Germany
Hi all,

i have been told from some freinds that they installed Win7 on even older machines and they rate performance as well as overall experience to be better with Win7 than XP.

My question:

1.) will it be even possible to install Win7 on an "antique" T42 (Type 2373-CTO) having 2GB Ram and will I get the necessary drivers (where from)?

2.) Has someone done it and can state about performance?

Thanks in advance
Juergen

_________________
R30, R31, T42, R50, R52 and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes and the use of a PC as a modern tool.


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 8:46 am 
Offline
Moderator
Moderator

Joined: Tue Jun 07, 2005 6:57 am
Posts: 9671
I did it on my T42 with the top end ATI Mobility Radeon 9600 GPU, and top end 1.7 GHZ CPU - IBM model 2378-FVU. I am satisfied with the performance and still have it installed. Not sure I would recommend it on one of the lower end GPU T42s - although I haven't tried it with one of those.

http://www.thinkwiki.org/wiki/2378-FVU

_________________
DKB


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 10:22 am 
Offline
Freshman Member

Joined: Wed Nov 21, 2007 11:10 am
Posts: 89
Location: Karlsruhe Germany
Seems mine shall be allmost equal.

Any tips as to where to get the drivers for Win7 from?

Especially, I would expect trouble at:

- the graphics (ATI MOBILITY RADEON 9600 Series) and the
- hot swap Ultrabay
- Wireless (Intel PRO 2200 BG)
- LAN (Intel PRO 1000 Mobile Connection)

maybe the battery also?

Thanks in advance
Juegen

_________________
R30, R31, T42, R50, R52 and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes and the use of a PC as a modern tool.


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 11:24 am 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Sat Oct 29, 2005 6:20 am
Posts: 5592
Location: Israel
The only thing I would expect trouble with is the graphics driver. From an experience of installing Win7 on a very similar laptop (X32 with the same network adapters you mentioned), they are either picked up on the fly, or there are good drivers by Lenovo/Intel.

But there were no drivers that I could find for the outdated Mobility Radeon on the X32. There are also no official drivers for the Radeon 7500, although with the much newer 9600, you can be more lucky.

What problems you may have without a proper video driver?
* Lack of proper sleep modes if you use the standard VGA adapter
* Crashes (esp. with Power Manager) if you use a third-party unapproved driver
* Limited or no support for high resolutions / multi-monitor setups
* Non-functioning power modes (assuming Power Manager doesn't crash completely)
* probably a few other issues

In the end, I managed to get almost everything to work on my X32 with an appropriate version of the XP Omega Drivers, that --sort of-- work.

However, like I said, you may be more lucky and find an official driver for the 9600.

_________________
Current: X220 4291-4BG, T410 2537-R46, T60 1952-F76, T60 2007-QPG, T42 2373-F7G, X61 7673-V2V
Collectibles: X32 w/ IPS Screen, A31p w/ Ultrabay Numpad
Past: Z61t 9440-A23, T60 2623-D3U, X32 2884-M5U


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 2:02 pm 
Offline
Moderator
Moderator

Joined: Tue Jun 07, 2005 6:57 am
Posts: 9671
You can get the video driver and WiFi driver from Windows Update. Aero does work with that driver.

Lan works out of the box as I recall. You can use the "Safely Remove Hardware and Eject Media" icon on the taskbar to remove Ultrabay devices.

_________________
DKB


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 3:39 pm 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Sun Feb 25, 2007 11:28 am
Posts: 12382
Location: Albrightsville, Pennsylvania
Radeon 9600 is actually the "lowest" GPU found in ThinkPads that is supported by Vista/W7 and everything should work pretty much out of the box...

Happy upgrading.

_________________
...Knowledge is a deadly friend when no one sets the rules...(King Crimson)

Cheers,

George (your friendly retired FlexView farmer)

Collecting SSDI: A31p, T42p

Abused daily: T43pSF, T60, T61, R60F, R500F

For sale: T601 QXGA


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sun Mar 18, 2012 4:08 pm 
Offline
Freshman Member

Joined: Wed Nov 21, 2007 11:10 am
Posts: 89
Location: Karlsruhe Germany
sounds great. thanks to all for your support!

will try out then ... backup first ... lol.

Juergen

_________________
R30, R31, T42, R50, R52 and some other "regular stuff" pc's.
Addicted to Music, Lotus Notes and the use of a PC as a modern tool.


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Tue Mar 20, 2012 2:03 pm 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Fri Sep 30, 2005 3:27 am
Posts: 2249
Location: Glendora, CA
I had Windows 7 running just fine on my old T41P, T42 and now my T43.

As already mentioned you might have a slight issue with the graphics driver. (I never did).

You could install the software update manager from lenovo and let it grab all your drivers for you.

_________________
New:
Dell Latitude D630 T7300, 4GB DDR2, 500GB HD, DVDRW, Intel GPU

Old:
Dell Latitude E6500, E6520, Precision M440 (Still in use)
ThinkPad Tablet 16GB 1838-22U
IBM Thinkpad X61T, T61, T43, X41T, T60, T41P, T42, T410


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Tue Apr 17, 2012 12:18 pm 
Offline

Joined: Mon Jul 09, 2007 6:05 am
Posts: 8
Location: Skipton, UK
Did install Windows 7 32bit on a T42 with the Radeon 7500 and although Windows told me there was some kind of problem with the driver, it actually ran fine. Switched back to XP so that I could use the Audigy 2 ZS notebook card.

_________________
IBM T20, P3 700Mhz, 512mb, 100Gb, WiFi :D 8mb video... :'(
--- Proudly breathing new life into an old T20 :D ---


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Thu Apr 19, 2012 1:47 am 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Fri Sep 30, 2005 3:27 am
Posts: 2249
Location: Glendora, CA
cultofbyron wrote:
Did install Windows 7 32bit on a T42 with the Radeon 7500 and although Windows told me there was some kind of problem with the driver, it actually ran fine. Switched back to XP so that I could use the Audigy 2 ZS notebook card.



Yep. I did not have Aero.

I did have Aero on my T41P and have it now on my T43.

_________________
New:
Dell Latitude D630 T7300, 4GB DDR2, 500GB HD, DVDRW, Intel GPU

Old:
Dell Latitude E6500, E6520, Precision M440 (Still in use)
ThinkPad Tablet 16GB 1838-22U
IBM Thinkpad X61T, T61, T43, X41T, T60, T41P, T42, T410


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Thu May 17, 2012 5:44 am 
Offline

Joined: Wed Jan 06, 2010 9:15 am
Posts: 6
Location: Rouen, France
I have installed Win7 on my t42p (fireGL video) 2ghz 2gig ram, everything is working perfectly.
I have an SSD in it, and performance is great. way better than XP, and way more usable as well.

I have no problem hibernating or suspending, wifi is rock stable (2200BG) (using windows wifi manager, not the lenovo one I never could understand)


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Fri May 18, 2012 6:15 pm 
Offline
Moderator
Moderator

Joined: Mon Mar 07, 2005 2:00 pm
Posts: 1796
Location: Copenhagen, Denmark
Riendf wrote:
I have installed Win7 on my T42p (FireGL video) 2 GHz 2 GB RAM, everything is working perfectly.
I have an SSD in it, and performance is great. way better than XP, and way more usable as well.

I have no problem hibernating or suspending, wifi is rock stable (2200BG) (using windows wifi manager, not the lenovo one I never could understand)

In relation to the above post, please share with us:

1) What version of Windows 7 did you install on your T42p? [Home, Professional, Ultimate?]

2) What SSD (what manufacturer and the specific model, and especially: Is it a SATA or PATA/IDE SSD?) do you use?

3) Do you use the SSD in the main T42p harddisk bay, or do you use the SSD in the UltraBay?

The reason for asking about details of the above is that I myself is very interested in using a 1.8" SATA SSD in internal main HDD bay in my T42p, through using the 1.8"-SATA-to_2.5"-PATA (eBay) adapter, as discussed in the threads 1.8" SATA to 2.5" IDE converter? and T42 SSD Conversion Success (1.8" SATA drive + bridge board). This solution is however a bit unstable (as e.g. discussed in this post so I am therefore highly interested to hear about any T42/p users who have succesfully installed a fast SATA SSD in their internal, main HDD bay.

Thanks in advance for sharing this highly interesting information! :bow:

Johan

_________________
IBM T42p's (2373-Q1U & -Q2U): 2.1 GHz, 15" UXGA FlexView, 2 GB RAM, 128 MB FireGL T2, 128 GB 1.8" SATA SSD, IBM a/b/g, BT, Win 7 Ultimate
IBM T42 (2373-N1G): 1.8 GHz, 15" SXGA+ FlexView, 2 GB RAM, 64 MB Radeon 9600, 64 GB 1.8" SATA SSD, IBM a/b/g, BT, Win 7 Ultimate


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Sat May 19, 2012 5:36 pm 
Offline

Joined: Wed Jan 06, 2010 9:15 am
Posts: 6
Location: Rouen, France
I installed both win7 ultimate and home (currently running home, ultimate migrated to another computer) Both are about the same to me, the only feature I used from ultimate was the remote desktop server.

I use a PATA SSD
G-Monster-IDE V2 SSD 32GB ATA Device (Fotofast) I use it for at least two years without any problems.
And it is my main hard drive, had nothing to do to have it recognised.

And the exact model of the computer is 2373-y3b
I did not try booting from it from the ultra bay, but I do not think it would be a problem.


basically it maxes out the patas interface at 68mb average and it only freezes when I try to write two big files at the same time. (In normal condition, I never have any freeze at all)


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Tue Jun 26, 2012 6:37 am 
Offline

Joined: Tue Feb 15, 2011 5:47 pm
Posts: 3
Location: Warsaw, Poland
I have win 7 pro on T42p 1.8 with FireGl T2 (Radeon M6). 1,3GB RAM. Wifi Intel a/b 2100, audio soundblaster audigy 2 zs pcmcia - everything works great, much better than on xp pro.


Top
 Profile  
 
 Post subject: Re: WIN 7 & T42
PostPosted: Wed Nov 21, 2012 5:45 pm 
Offline

Joined: Wed Nov 21, 2012 5:22 pm
Posts: 4
Location: Oslo, Norway
First post :D
I have a T42 (2376 DN9) with 755 2.0 GHz / 2GB / ATI 9600/9700 / SXGA+ with Win7 Ultimate installed, works like a dream, no problems at all.
(I did the CPU and RAM upgrades, it was originally 1.7GHz / 1GB)

The OS was already installed when I purchased it second-hand a few years ago, so I do not know of any driver problems when it was set up, but as I said, doesnt sem to be any problems now.
The video driver is from ATI, dated 10.02.2010 and seems to work fine.
I have just ordered a SATA caddy and an Intel 330 Series SSD, with that I think there are no more upgrades I can put on this laptop, it will last me at least a few more years I hope!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group