thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
IBM & lenovo legacy model ThinkPad support files are available on thinkpads.com.
including Hardware Maintenance Manuals, latest or final driver updates and more.
at: thinkpads.com


If you so wish:
Donate using PayPal

It is currently Mon Dec 22, 2014 2:02 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Windows 7 on a T43
PostPosted: Fri Jan 16, 2009 5:41 pm 
Offline

Joined: Thu Jul 31, 2008 2:46 am
Posts: 13
Location: Kelowna, Canada
Hello! Recently I installed the Windows 7 public Beta on my T43. So far, everything about the OS is super stable, and everything works. I have run into a few issues with drivers, specifically the drivers for the built in Intel Pro/Wireless 2200BG card. I have tried everything I know to get the wireless to work properly!

I have got it to the point that it installs Intel's drivers, but only lets me install the wrong ones. Lenovo System Update recognizes that it needs new drivers, and proceeds to download an install them. But after a reboot, no changes were made, and System Update sees that it needs to update the drivers and tries again. If I force drivers downloaded from Intel, the device shows an error saying that the "Device Failed to Start". I installed Access Connections for windows Vista, which runs beautifully, but it also doesn't recognize that there are any wireless adapters installed, and pressing Fn+F5 does nothing.

So I struggled with installing the drivers for my wireless card for a night, then gave up. So I rebooted and the screen telling me to interrupt the startup by pressing the Access IBM key comes up, I press it, the notice goes away like normal, but it proceeds to boot into windows 7. Shoot, Windows 7 wrote over my mbr. Even worse, Windows 7 uses a different boot system than any previous version of windows! Uh-oh...

So I have two questions.

1. Anybody have any ideas on how to get the Wireless adapter working properly?

2. How can I restore the functionality of the Blue Access IBM button? Preferably, without using floppy's, since I don't have a usb floppy drive!

Any help on the matter would be GREATLY appreciated!


Top
 Profile  
 
 Post subject: Re: Windows 7 on a T43
PostPosted: Fri Jan 16, 2009 6:12 pm 
Offline

Joined: Thu Jul 31, 2008 2:46 am
Posts: 13
Location: Kelowna, Canada
UPDATE!!

I just thought, hey, maybe I'll give the Windows XP drivers for my wireless card a go.

It works. Windows XP drivers for the Intel Pro/Wireless 2200BG card DO work in Windows 7


Top
 Profile  
 
 Post subject: Re: Windows 7 on a T43
PostPosted: Fri Jan 16, 2009 6:40 pm 
Offline
Freshman Member

Joined: Sun Dec 30, 2007 6:47 pm
Posts: 107
Location: Kingston, Ontario
I just downloaded a vista wireless driver to get it to work.

Windows 7 is a little slow when opening programs, everything else is great.

_________________
eMac G4/768 MB RAM/ 80 GB HD/OS X Leopard


Top
 Profile  
 
 Post subject: Re: Windows 7 on a T43
PostPosted: Wed Sep 14, 2011 2:45 pm 
Offline

Joined: Wed Sep 14, 2011 2:36 pm
Posts: 1
Location: Vienna, Austria
I recently had to reinstall WIndows 7 on my TP 43 and ran into the graphics driver issue for Intel 915GM/GMS 910 GML Express Chipset Family. Levnovos Driver website specifies an XP Driver which does not work and gets removed by WIndows 7 after each system restart, if istalled with XP compatibility.
Finally I found a working driver on Intels's website:
http://downloadcenter.intel.com/confirm ... ss+Chipset
Unzip, and install using setup.exe under XP SP 2 Compatibility and administrator rights (click right on the setup exe file) it does the job.
I hope this helps some other TP43 owners.


Top
 Profile  
 
 Post subject: Re: Windows 7 on a T43
PostPosted: Wed Sep 14, 2011 5:42 pm 
Offline
Freshman Member

Joined: Fri Oct 30, 2009 8:11 am
Posts: 123
Location: Iron Mountain, MI. USA
Hi,


Has anybodyfound the driver for the Biometric Coprocessor?

MnR

_________________
No one is listening, Until you make a mistake...
The U.P of Michigan, The 51st State.


Top
 Profile  
 
 Post subject: Re: Windows 7 on a T43
PostPosted: Thu Sep 15, 2011 5:12 pm 
Offline
Moderator
Moderator

Joined: Tue Jun 07, 2005 6:57 am
Posts: 9696
MnR wrote:
Hi,


Has anybodyfound the driver for the Biometric Coprocessor?

MnR

Give this a try: http://support.lenovo.com/en_US/downloa ... MIGR-73585

_________________
DKB


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group