thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
Our oldest longest advertiser of parts for ThinkPads
NOTICE: IF you receive a message saying your IP is banned, please read the post: ** IP Banned..? Please read me ** in Forum Announcements..

The SpamBot attack has slowed way down, most likely because christmas advertising is over for now..
We are still working on ways to prevent most or all SpamBots in the future..


If you've found this forum useful, please consider donating a dollar or two

It is currently Sun Jan 25, 2015 1:17 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Thu Feb 02, 2012 9:15 am 
Offline
Freshman Member

Joined: Wed Feb 09, 2005 1:51 pm
Posts: 118
Location: Ottawa, Canada
I'm trying to revive an old 600X (Win 2K) and I've got everything working except for the USB port.

A couple quick questions:
a.) is the USB port enabled in BIOS (it's on 47WW but I'm afraid to update it - I suspect the hard disk is going to go at any minute and I want to get the data off first)?
b.) where would I find the 600X USB driver (I looked on the Lenovo site - http://goo.gl/iqOEc - and found nothing)

TIA. Regards.

_________________
John Treble

ThinkPad: 600E/X, T23, T41p, T60 and W520. IntelliStation: M Pro. ThinkStation: D20. ThinkVision: L190/1/2/3p.


Top
 Profile  
 
PostPosted: Thu Feb 02, 2012 3:28 pm 
Offline
Senior Member
Senior Member

Joined: Mon Dec 12, 2011 9:00 am
Posts: 606
Location: United States
On my 390X, which is a cousin to the 600X, does not have an option for enabling USB in the BIOS. I can only enable/disable Trackpoint, parallel port, serial port, VGA, PCMCIA slots, Infrared, and modem.

There is no Lenovo driver for USB. USB support is built into all Windows versions since Windows 95 OSR2.

What shows up in device manager? Do you have unknown devices? What is your IRQ configuration?

I would leave the BIOS alone if it were me.

Get an IDE/SATA to USB adapter to get the data off the hard drive. You could also use ethernet if you have that capability with it.

_________________
jayton4
Current models/upgrades:
T410 2518X01- 8GB, Corsair Force GT 120GB
T410s 2901A3U- 8GB, Intel 6300 WiFi, Crucial m4 mSATA 256GB SSD w/ microSATA adapter
T420s 4174PPU- 16GB, Intel 520-series 7mm 180GB SSD, Crucial M550 512GB mSATA SSD, Intel 6300 WiFi
and a few classics in storage


Top
 Profile  
 
PostPosted: Thu Feb 02, 2012 9:08 pm 
Offline
Freshman Member

Joined: Wed Feb 09, 2005 1:51 pm
Posts: 118
Location: Ottawa, Canada
> jayton4 ...
>
> Do you have unknown devices? ...

Exactly. I've managed to image the hard drive using a PCMCIA 1394 card. The USB problem, however, is a puzzler. Thanks for your help.

_________________
John Treble

ThinkPad: 600E/X, T23, T41p, T60 and W520. IntelliStation: M Pro. ThinkStation: D20. ThinkVision: L190/1/2/3p.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group