thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Fri Jul 25, 2014 10:22 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 17 posts ] 
Author Message
PostPosted: Mon Sep 15, 2008 11:57 am 
Offline

Joined: Wed Nov 21, 2007 6:16 am
Posts: 30
Location: Eindhoven, Netherlands
Hi,

Thought I'd share my whole Extensions folder now that my install works great. This is for the T60p 8741-AE5:

Graphics: ATI FireGL V5250 256MB
Display: 15.4" 1680x1050 WSXGA display
Audio: Intel HD Audio

I recommend that you trash the contents of your Extensions folder, and then use Kext Helper b7 to install ALL of the kexts in my folder.

Grab them here: http://rapidshare.com/files/145496071/E ... s.zip.html

Post here if you need help.

By the way: use at your own risk. Keep an install disk ready, preferably make a Time Machine backup before trying out these kexts, so you can recover from whatever trouble this may cause you.

_________________
T60p | 2,0GHz Core2Duo | 2GB/667 | 320GB/7200 | FireGL V5250 | Mac OS X Leopard 10.5.6


Last edited by finetuned on Wed Sep 17, 2008 4:30 am, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 16, 2008 10:15 am 
Offline

Joined: Sat Feb 17, 2007 3:01 pm
Posts: 33
Location: Cupertino CA
Just a short question before downloading the 80mb pack and probably replacing all my kexts.

Is the internal mic / sound in working with on your computer?
This is only thing that doesn't work on my t60p.


and also for those just updated to 10.5.5, here are the new kexts for t60p's with atheros and v5250.
http://www.mediafire.com/?wmmkcma5aiw


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 16, 2008 5:52 pm 
Offline

Joined: Wed Nov 21, 2007 6:16 am
Posts: 30
Location: Eindhoven, Netherlands
No — The audio input of the on-board audio device does not work. I always use an external interface.

_________________
T60p | 2,0GHz Core2Duo | 2GB/667 | 320GB/7200 | FireGL V5250 | Mac OS X Leopard 10.5.6


Top
 Profile  
 
PostPosted: Wed Sep 17, 2008 2:00 am 
Offline
Sophomore Member

Joined: Wed Apr 18, 2007 10:37 pm
Posts: 217
Location: Pittsburgh, PA
finetuned wrote:
...everything works....
Graphics: ATI FireGL V5250 256MB
...


Finetuned, does "everything" include a working VGA port to connect to extend the desktop to an external monitor? or a project for presentation?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 17, 2008 4:29 am 
Offline

Joined: Wed Nov 21, 2007 6:16 am
Posts: 30
Location: Eindhoven, Netherlands
Yes — "everything" includes that. Want me to list every little thing that works? okay, here we go:

Graphics:
QE, CI, QGL, res change, native res, VGA output port, mirror, extended desktop, display sleep, display wake, no mouse tearing

Audio:
Speakers, headphone output

Network:
Ethernet, WiFi, Bluetooth

Hard drive:
works

Memory:
Correctly recognised as 667MHz 2GB (in my case)

CPU:
Both cores, correctly recognised as Intel Core2Duo

Cardbus:
Yes, works (tested with PCMCIA Firewire card)

Mouse:
TrackPoint and TrackPad work (no 2-finger scrolling, no middle button on the TrackPoint controls)

Time Machine:
Yes, works (no problems with "backup volume not found")

DVD burning:
Works (correct IOATAFamily.kext)

Sleep:
Works (correct SMBIOS and removed the two *LPC*.kext)

Speedstep:
Works, using correct IntelEnhancedSpeedStep.kext and SpeedStep v2 beta. No kernel speedstepping, but it works (4 levels: 1000, 1333, 1667, 2000). The Fan also adjusts speed according to temperature.

Battery meter:
Yes, works.



Things I haven't tested:
IR, Modem, Docking station connector


Things that don't work:
Middle mouse button scrolling

_________________
T60p | 2,0GHz Core2Duo | 2GB/667 | 320GB/7200 | FireGL V5250 | Mac OS X Leopard 10.5.6


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 17, 2008 1:33 pm 
Offline
Sophomore Member

Joined: Wed Apr 18, 2007 10:37 pm
Posts: 217
Location: Pittsburgh, PA
Congrats!!! That's a machine with superior hardware and a BSD-based fancy OS!!!
I'm Jealous. Do you know if ATI FireGL V5200 (on T60p 4:3) can work as perfectly as the ATI FireGL V5250? I'm planning to get the motherboard of my 15" T60 swap for a better installation of OSX86...

I guess you may have to test the internal microphone too :wink:

For the middle mouse button, have you tried Smart Scroll? You can buy it or you can try it forever...
http://marcmoini.com/sx_en.html
In the option, Grab Scroll, select options so that pointer doesn't move while scrolling, and reverse X and reverse Y direction during scrolling.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 17, 2008 2:16 pm 
Offline

Joined: Wed Nov 21, 2007 6:16 am
Posts: 30
Location: Eindhoven, Netherlands
Yes — I think the V5200 will also work fine, but not with my kexts. You will have to modify them. PM me for more info.

_________________
T60p | 2,0GHz Core2Duo | 2GB/667 | 320GB/7200 | FireGL V5250 | Mac OS X Leopard 10.5.6


Top
 Profile  
 
 Post subject:
PostPosted: Fri Sep 19, 2008 8:04 am 
Offline

Joined: Wed Sep 10, 2008 2:58 pm
Posts: 15
Location: Andover, MA
Wow! Thanks so much for posting this! I'm hoping the T60p-8743 is close enough to what you have for this to work.

Off to check the differences between the two machines...


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 21, 2008 10:26 am 
Offline

Joined: Mon Feb 12, 2007 4:59 pm
Posts: 1
Location: UK
finetuned wrote:
Yes — I think the V5200 will also work fine, but not with my kexts. You will have to modify them. PM me for more info.


Hi
what distro( kalyway ,jas leo4all....) are you using and what version have you successfully upgraded to ?
Regards


Top
 Profile  
 
 Post subject:
PostPosted: Sun Sep 21, 2008 2:06 pm 
Offline

Joined: Wed Sep 10, 2008 2:58 pm
Posts: 15
Location: Andover, MA
I tried these on my T60p-8743cto w/ Kalyway install (upgraded to 10.5.4) and it worked perfectly. I then upgraded that install to 10.5.5 and had video driver issues (I didn't see the post above regarding drivers for 10.5.5). I then used iDeneb 1.1 (10.5.4) and again, these extensions worked very well, but the power management is non-existent, an oddly, my sound wasn't working until I upgraded to 10.5.5. So, now I'm 10.5.5 and everything is working except for power management. Maybe i have the wrong kernel?


Top
 Profile  
 
 Post subject:
PostPosted: Wed Oct 01, 2008 9:41 am 
Offline

Joined: Sat Feb 17, 2007 3:01 pm
Posts: 33
Location: Cupertino CA
finetuned wrote:
No — The audio input of the on-board audio device does not work. I always use an external interface.


Which external interface do you use?

Skype crashes as soon as a call is connected on my machine.
I guess it's because of the incompatible sound driver.

Could you test if skype works with your external interface?

Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Sat Oct 04, 2008 9:23 pm 
Offline

Joined: Fri Oct 03, 2008 7:29 pm
Posts: 8
Location: Boston, Mass
maybe a dumb question, but I'm sort of new to this OSX86 scene, will these work on any 8741? I have an 8741-CTO and I can't seem to get Sleep or QE/CI to work for the life of me, and I spent all day at work bouncing between these forums, InsanelyMac forums, and google... :x

Any input at all would be appreciated, thanks


Top
 Profile  
 
 Post subject:
PostPosted: Sun Oct 05, 2008 11:35 pm 
Offline

Joined: Fri Oct 03, 2008 7:29 pm
Posts: 8
Location: Boston, Mass
Neon Dion wrote:
maybe a dumb question, but I'm sort of new to this OSX86 scene, will these work on any 8741? I have an 8741-CTO and I can't seem to get Sleep or QE/CI to work for the life of me, and I spent all day at work bouncing between these forums, InsanelyMac forums, and google... :x

Any input at all would be appreciated, thanks
I just backed up my Extensions and tried it today, and it works perfectly, thanks for the share man!


Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 03, 2008 5:33 pm 
Offline

Joined: Mon Nov 03, 2008 10:50 am
Posts: 2
Location: Eindhoven, Netherlands
This seems to work fairly well for me, one issue though: closing the laptop lid totally messes up the display. The only option is to reboot. Any ideas how to fix this?

_________________
T60p 8741-AE5


Top
 Profile  
 
 Post subject: Re:
PostPosted: Mon Mar 09, 2009 4:33 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
finetuned wrote:
Sleep:
Works (correct SMBIOS and removed the two *LPC*.kext)


Quick q. Which SMBIOS did you use? Is it completely custom or something that was included in the installation package? It's just there are so many of them and most of them work fine (I've tried at least four versions), but Sleep still gives me troubles. Also, I know about AppleLPC.kext in Extensions folder. Which one is the other?

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
PostPosted: Wed Sep 22, 2010 1:46 pm 
Offline

Joined: Wed Sep 22, 2010 1:37 pm
Posts: 2
Location: Oklahoma City, Oklahoma USA
will these ext work with 10.6.2 ?
I just download them.

Any Idea? I also have a T60p 8741.
September, 2010.
Thanks


Top
 Profile  
 
PostPosted: Wed Sep 22, 2010 2:10 pm 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
correohs wrote:
will these ext work with 10.6.2 ?
I just download them.

Any Idea? I also have a T60p 8741.
September, 2010.
Thanks

If those extensions are for 10.5.x (judging by the signature of the original poster), then I wouldn't recommend using them with 10.6.x. They might work, but will give you more problems than benefits. Putting together an OSX for T60p from scratch is not that big deal. Check out some guides in this forum, there are plenty.

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group