thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Sun Apr 20, 2014 11:34 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 89 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Snow leopard on X60s
PostPosted: Wed Mar 03, 2010 10:05 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
I noticed that DSDT SpeedStep doesn't work at all with VoodooBattery ... that would explain your 60° idle temp and that's why i used AppleACPIBattery which is compatible .

I guess VanillaSpeedStep can also be improved : I just copy/paste the C-States from Silencer's, I have a very good idle temps around 45° but I also have audio/video lags ... for the moment I am still using VoodooPower !

About Audio and Sleep, I already tried Azalia and VoodooHDA in almost every configuration (E/E, S/L/E), sleep works but no keyboard and no mouse on wake ... According to me it comes from PS2 driver which cannot wake the track point for some reason ...

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Wed Mar 03, 2010 10:22 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
Sebinouse wrote:
I guess VanillaSpeedStep can also be improved : I just copy/paste the C-States from Silencer's, I have a very good idle temps around 45° but I also have audio/video lags ... for the moment I am still using VoodooPower !


Lag is easy to fix - check my guide and find DSDT fixes for PIC and TIMR devices.

Sebinouse wrote:
About Audio and Sleep, I already tried Azalia and VoodooHDA in almost every configuration (E/E, S/L/E), sleep works but no keyboard and no mouse on wake ... According to me it comes from PS2 driver which cannot wake the track point for some reason ...


What PS2 kexts are you using? I have now no problem with waking and using keyboard or trackpoint.

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Wed Mar 03, 2010 3:16 pm 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Silencer wrote:
Lag is easy to fix - check my guide and find DSDT fixes for PIC and TIMR devices.

... you are right that one was really easy to fix ! (I should have paid more attention reading your guide !)

Silencer wrote:
What PS2 kexts are you using? I have now no problem with waking and using keyboard or trackpoint.

I have tried many of them ... including yours ...

My problem is with ApplePS2Mouse.kext ... once deleted sleep/wake works ! But I really don't understand why !
I am still looking for a solution (my X60 is a tablet so I can use a pointer instead of the trackpoint ...)

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Mar 04, 2010 3:37 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
Sebinouse wrote:
My problem is with ApplePS2Mouse.kext ... once deleted sleep/wake works ! But I really don't understand why !
I am still looking for a solution (my X60 is a tablet so I can use a pointer instead of the trackpoint ...)


Pointer - you mean trackpad or trackpoint? Red nubbin is trackpoint :)

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Mar 04, 2010 8:15 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
I mean the magnetic pen provided with the x60t to use directly on the screen ... it's a real TabletMac with either Sleep or trackpoint (the x60t has no trackpad)

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Mar 04, 2010 8:26 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
Sebinouse wrote:
I mean the magnetic pen provided with the x60t to use directly on the screen ... it's a real TabletMac with either Sleep or trackpoint (the x60t has no trackpad)


Oh, in that case I won't be able to help, since I have to means of testing this.

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Mar 04, 2010 8:37 am 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
he probably means the tablet pen.

i'm following this thread for a while. i have a x60t and i'm running leopard currently. as soon as sleep is working reliably i'll make the switch.


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Fri Mar 05, 2010 12:37 pm 
Offline
Freshman Member

Joined: Sat Jul 12, 2008 5:22 am
Posts: 66
Location: Rouen, France
Well, *beep* me, sleep works on my X60s. Perfectly. I finally had the time to carefully read Silencer's DSDT thread and to try Sebinouse's Extra folder, and voilà, it works like a charm. So all credit goes to you guys. I even get the Trackpoint back on wake using VoodooPS2 instead of ApplePS2Controller (this version: http://forum.voodooprojects.org/index.p ... 718.0.html , and you should remove the Mouse plugin from inside the kext).

Now, I will concentrate on the last missing piece: Vanilla Speedstep. I am using the DSDT and legacy kext from Sebinouse but for some reason it does not work (no c-states), even though we have the exact same CPU.

Also, this is not a priority, but I found this thread relating to the Firewire error messages on boot: http://forum.voodooprojects.org/index.php?topic=200.0 . What I don't understand is that according to the thread, it should already work.

Anyway this is unbelievably great news! I sold my X200s in December to get a more OS X-compatible Thinkpad, and now I am really glad I did.


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Sat Mar 06, 2010 7:54 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
martin255 wrote:
Now, I will concentrate on the last missing piece: Vanilla Speedstep. I am using the DSDT and legacy kext from Sebinouse but for some reason it does not work (no c-states), even though we have the exact same CPU.


Extract your SSDT tables as explained in my guide, and send me your DSDT, SSDT, SMBIOS.plist and legacy kext you're using. I will then have a look, where you might have a problem.

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Sat Mar 06, 2010 8:35 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
martin255 wrote:
Well, *beep* me, sleep works on my X60s. Perfectly. I finally had the time to carefully read Silencer's DSDT thread and to try Sebinouse's Extra folder, and voilà, it works like a charm. So all credit goes to you guys. I even get the Trackpoint back on wake using VoodooPS2 instead of ApplePS2Controller (this version: http://forum.voodooprojects.org/index.p ... 718.0.html , and you should remove the Mouse plugin from inside the kext).


Good news ! Even if it doesn't work for me ... I have still the same ApplePS2Mouse issue on wake ... by the way did you remove the Mouse plugin or the Trackpad plugin ?

And for the vanilla speedstep ... I used a MacbookPro1,1 model for the smbios.plist / legacy kext and I never generated SSDT table I just pasted the content of Silencer's ... and it worked for me ... to get the SSDT table you can use ACPIDumper

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Mon Mar 08, 2010 7:30 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Finally I got my X60t to wake properly ! :banana: :at last: :banana:

The problem was due to unexpected data from ApplePS2Mouse.kext, so I tried to use SleepWatcher ... and i made 2 script (rc.sleep and rc.wakeup) to unload AppleACPIPS2Nub.kext and ApplePS2Controller.kext from /E/E/ on sleep and load them on wake ...

You can download the files here
Place rc.sleep and rc.wakeup in /etc/
chmod +x these two files
That's it !

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Mar 11, 2010 8:48 pm 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
Sebinouse wrote:
Finally I got my X60t to wake properly ! :banana: :at last: :banana:


can you summarize what's working for you, and what not at the moment? and also, what installation method did you use? sorry for asking noob questions, i'm beginner with os x.

is tablet mode working with tablet magic?

could you maybe post all of your kexts, dsdt and all changed files? i have the latest x60t bios 1.15 which is out for quite a while, so i suppose you probably have the same and i won't have to go through the hazzle of dsdt patching myself.

i have put an atheros ar9280 wifi into my x60t (with hacked bios), it's an original apple pcie card from latest 2009 macbook pro - full 11n with just 2 antennas. it's the main reason for upgrading, because the card doesn't work in leopard and the old atheros card didnt work well.


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Fri Mar 12, 2010 7:20 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
ernstloeffel wrote:
can you summarize what's working for you, and what not at the moment? and also, what installation method did you use? sorry for asking noob questions, i'm beginner with os x.

is tablet mode working with tablet magic?


Everything is working except VGA-Out, IRda, PCMCIA Slot-in, and I have no way to test firewire ...

ernstloeffel wrote:
could you maybe post all of your kexts, dsdt and all changed files? i have the latest x60t bios 1.15 which is out for quite a while, so i suppose you probably have the same and i won't have to go through the hazzle of dsdt patching myself.


I have never updated my bios ... I gonna check the version on next reboot. mine is 1.08 ...
The link for my files can be found in this thread : old installation method, updated EE to keep SLE clean ... I will update this guide when i have enough time ...

ernstloeffel wrote:
i have put an atheros ar9280 wifi into my x60t (with hacked bios), it's an original apple pcie card from latest 2009 macbook pro - full 11n with just 2 antennas. it's the main reason for upgrading, because the card doesn't work in leopard and the old atheros card didnt work well.


You just have to edit info.plist in Atherosfix.kext or LegacyX60t.kext and modify the Vendor/Devide Id.

Keep us adviced ... :wink:

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Last edited by Sebinouse on Fri Mar 12, 2010 8:23 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Fri Mar 12, 2010 8:20 am 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
thank you for your summary.

Sebinouse wrote:
You just have to edit info.plist in Atherosfix.kext or LegacyX60t.kext and modify the Vendor/Devide Id.


i think my new card *should* just work without any changes, i'll report back here. besides the probs i had with the old original atheros ar5001x+ under os x, another reason for upgrading the wifi card was that the new 9-series consumes considerably less power, has 11n and has optimized drivers for windows 7 (the old card drew ~ 8w when downloading large files with 2 mb/s where the new card consumes max ~ 4w).


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Fri Mar 12, 2010 11:22 am 
Offline
Freshman Member

Joined: Sat Jul 12, 2008 5:22 am
Posts: 66
Location: Rouen, France
Here are the file you requested, Silencer: http://dl.dropbox.com/u/602349/X60s-martin255.zip I would be really grateful if you could have a look someday. I don't have much time to tinker at the moment, but I will try to work on it on my own too.

Anyway, other than that everything works pretty well. I lose brightness control when waking from sleep, though, so I will probably switch back to Fn+Home/End.


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Fri Mar 12, 2010 11:48 am 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
Sebinouse wrote:
I have never updated my bios ... [snip] mine is 1.08 ...


that's really old. there have been a lot of fixes since then, including acpi fixes and in particular a "lid close" fix in 1.12

have a look here:
http://www-307.ibm.com/pc/support/site. ... 48#changes


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Mon Mar 22, 2010 6:23 pm 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
i gave sl a try now. my atheros ar9280 is working since i updated to 10.6.2 out of the box.

however, sleep, sound and tablet don't work for me. i had tablet working, but then it stopped working and i don't see what caused it to stop working.

same with sound: it sometimes works, but then again it just stops working and sound control gets disabled.

same with sleep. i think i have patched my dsdt correctly, but only the hdd stops spinning when i close the lid and the screen remains active. also, the lid close event was working with another boot loader (i now use the recommended asere which fixes restart etc), but with the old boot loader the pc restartet as soon as i reopened the lid.

do you have a clue what's wrong?

i have uploaded my dsdt here:
http://www.mediafire.com/?dgku4j4ibwz

this is my extra folder (basically sebinhouses folder with altered voodoops2controller with new ultranav driver from other thread here, works for me):
http://www.mediafire.com/?0zjyz2goe2z


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Mon Mar 22, 2010 7:23 pm 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
ernstloeffel wrote:
sleep, sound and tablet don't work for me.


Here is my latest working config :
DSDT with DTGP/HPET/RTC/IOATAFamily/AHCI/Brightness/Speedstep/IntelGMA950/...
Extentions :
ApplePS2Controller (I think you can use VoodooPS2 but you have to delete ApplePS2 ...)
VoodooMonitor removed
AsereBLN 1.1.9

With this configuration Sound should work.

For sleep you have to installthese files (and update rc.sleep and rc.wakeup if you use VoodooPS2) as I did earlier in this thread.

For tablet, you config should work ... did you check "Launch Daemon on startup" in TabletMagic PrefPane ... My tablet stopped working under Leo when this box was checked

PS: Do you have an Intel GMA950 with the genuine screen ? My boot resolution is only 1024x768 ... and yours 1400x1050 !!!

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Mon Mar 22, 2010 8:04 pm 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
Sebinouse wrote:
ernstloeffel wrote:
sleep, sound and tablet don't work for me.

PS: Do you have an Intel GMA950 with the genuine screen ? My boot resolution is only 1024x768 ... and yours 1400x1050 !!!


thank you very much! i'm just running pfix now. i've a l7500 core2duo and indeed a genuine sxga+ screen. i'm now using a modified t60p legacy kext based on silencer for that reason (core2duo) and your dsdt.


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Mon Mar 22, 2010 9:06 pm 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
Sebinouse wrote:
ernstloeffel wrote:
sleep, sound and tablet don't work for me.

My boot resolution is only 1024x768 ... and yours 1400x1050 !!!


your dsdt doesnt work for me, it crashes at startup. i also figured that sound only crashes when i close the lid.

i also found that my resolution is stuck at 1280x1024... hmmm

EDIT: OK, I wiped my installation and did a fresh install. I had lots of trouble lately with Kernel Panics and didn't see the cause.

My current installation is this:
- Your Extra folder with my dsdt, an EFI string for the GMA 950 (otherwise I'm stuck with 1280*1024)
- Instead of the ApplePS2 stuff I use VoodooPs2 withe the new Ultranavi driver

On lid close the notebook does actually go into standby again. Nice... BUT: Now does again a hard reboot as soon as I reopen the lid...

I'm not sure whether the problem is in my DSDT or a configuration problem...


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Sun Apr 11, 2010 2:36 pm 
Offline

Joined: Sun Apr 11, 2010 1:57 pm
Posts: 34
Location: Toronto, Ontario, Canada
Hello guys,

My first post on this site.

Let me first say, that I have been using OSX for a couple years now on my X60 tablet.
I have it 99% working with 10.6.3 and thanks to this board, I finally have my MIC working!!
Now I can use Skype from this puter - weeee!

As for ernstloeffel's screen issue.
I have mine @ full resolution 1400x1050x32.

Try adding/changing your /Extra/com.apple.Boot.plist file:
<key>Graphics Mode</key>
<string>1400x1050x32</string>

I also have sleep working with SleepEnable.kext - no issues except for the no sound after wake.
For that I created an alias in my .profile (file):

alias restartaudio='sudo kextunload /System/Library/Extensions/VoodooHDA.kext; sleep 3; sudo kextload /System/Library/Extensions/VoodooHDA.kext'

So from the terminal prompt I just type 'restartaudio' when I wake up my "beast" to get sound back.
(I'm a *nix head and I always have a terminal open - so others may not want to go this route)
If you do use this alias, you may get a failure to unload the kext message, but it does it anyways and then reloads.

_________________
ThinkPad X60 Tablet (6363-C7U)
Intel Core 2 Duo L7400(1.5GHz)
4GB Memory / Seagate ST9500420AS 500GB HD
12.1in 1400x1050 LCD ( Intel GMA950 )
SD Card / 9 Cell Battery / Bluetooth / Wifi Atheros AR5BXB72
MacOSX 10.6.4


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Fri Apr 16, 2010 10:10 am 
Offline

Joined: Tue Feb 02, 2010 10:26 pm
Posts: 22
Location: ventura, ca
Neflem wrote:
As for ernstloeffel's screen issue.
I have mine @ full resolution 1400x1050x32.

Try adding/changing your /Extra/com.apple.Boot.plist file:
<key>Graphics Mode</key>
<string>1400x1050x32</string>


i tried that too. however, as i recall, it depended a) on the boot loader (res would be stuck at 1280*1024 anyways with this param,eter) and b) the video performance has greatly improved with the efi string.


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Tue Apr 20, 2010 9:27 pm 
Offline

Joined: Sun Apr 11, 2010 1:57 pm
Posts: 34
Location: Toronto, Ontario, Canada
My bad, I too tested it by backing out my kexts and then using the original 10.6.3 kexts.

Well, I figure my kexts from (I think) 10.5.6 or 10.5.7 that I have been carrying forward to every new update is what will fix you up.

One issue I found, is that, once I updated to 10.6.3, I lost Quartz Extreme :(

The kext in question are:

AppleIntelGMA950.kext
AppleIntelIntegratedFramebuffer.kext


Here's the listing of the tar file:

drwxr-xr-x 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/
drwxr-xr-x 0 root wheel 0 16 Apr 09:19 System/Library/Extensions/AppleIntelGMA950.kext/Contents/
drwxr-xr-x 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/_CodeSignature/
lrw-r--r-- 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/CodeDirectory -> _CodeSignature/CodeDirectory
lrw-r--r-- 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/CodeRequirements -> _CodeSignature/CodeRequirements
lrw-r--r-- 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/CodeResources -> _CodeSignature/CodeResources
lrw-r--r-- 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/CodeSignature -> _CodeSignature/CodeSignature
-rw-r--r-- 0 root wheel 2515 16 Apr 09:19 System/Library/Extensions/AppleIntelGMA950.kext/Contents/Info.plist
-rw-r--r-- 0 root wheel 2513 16 Apr 09:18 System/Library/Extensions/AppleIntelGMA950.kext/Contents/Info.plist.original
drwxr-xr-x 0 root wheel 0 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/MacOS/
-rw-r--r-- 0 root wheel 9 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/PkgInfo
-rw-r--r-- 0 root wheel 456 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/version.plist
-rw-r--r-- 0 root wheel 358268 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/MacOS/AppleIntelGMA950
-rw-r--r-- 0 root wheel 162 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/_CodeSignature/CodeDirectory
-rw-r--r-- 0 root wheel 12 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/_CodeSignature/CodeRequirements
-rw-r--r-- 0 root wheel 1363 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/_CodeSignature/CodeResources
-rw-r--r-- 0 root wheel 4064 13 Apr 12:45 System/Library/Extensions/AppleIntelGMA950.kext/Contents/_CodeSignature/CodeSignature
drwxr-xr-x 0 root wheel 0 13 Apr 12:46 System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext/
-rw-r--r-- 0 root wheel 226716 13 Apr 12:46 System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext/AppleIntelIntegratedFramebuffer
-rw-r--r-- 0 root wheel 2310 13 Apr 12:46 System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext/Info.plist
-rw-r--r-- 0 root wheel 456 13 Apr 12:46 System/Library/Extensions/AppleIntelIntegratedFramebuffer.kext/version.plist


I've uploaded them here: http://www.mediafire.com/download.php?jmmf4jnyzym

Make sure you back up your originals.
And I hope it works for you!

_________________
ThinkPad X60 Tablet (6363-C7U)
Intel Core 2 Duo L7400(1.5GHz)
4GB Memory / Seagate ST9500420AS 500GB HD
12.1in 1400x1050 LCD ( Intel GMA950 )
SD Card / 9 Cell Battery / Bluetooth / Wifi Atheros AR5BXB72
MacOSX 10.6.4


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Apr 22, 2010 2:23 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
I also noticed something weird about 10.6.3 update and AppleIntelGMA950 :

In 10.6.0/1, I never had QE/CI written in System Profiler but it works (in fact Frontrow works and we assume that "Frontrow -> QE/CI enabled")

In 10.6.2, we had new 64bit drivers for IntelGMA950 : I had QE/CI enabled and written in SystProfiler ....

Now in 10.6.3, we have once again new driver, they no longer support x64 !!! and QE/CI does no longer appears in System Profiler !!! (but Frontrow works ...)

I going to investigate ... I keep you updated !

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Apr 22, 2010 5:28 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
I just reinstalled 10.6.2 ...

AppleIntelGMA950.kext and AppleIntelIntegratedFramebuffer.kext version 1.6.6.25 and they are compatible i386 and x64.

And now in 10.6.3, the version is 1.6.10 and they are no longer compatible with x64 ...

As I boot in i386 and QE/CI is enabled ... I'm fine with this update ... even if I don't see the point !

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Last edited by Sebinouse on Thu Apr 22, 2010 7:01 am, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Apr 22, 2010 5:43 am 
Offline
Junior Member
Junior Member

Joined: Sat Dec 25, 2004 8:17 pm
Posts: 345
Location: Riga, Latvia
Sebinouse wrote:
As I boot in i386 and QE/CI is enabled ... I'm fine with this update ... even if I don't see the point !

You can save older kext and then update to 10.6.3 and use the kext saved before.

_________________
ThinkPad T60p with Snow Leopard 10.6.8
Intel Core 2 Duo T7600
4GB RAM, ATI FireGL V5200 256MB (1400x1050)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Thu Apr 22, 2010 7:00 am 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Silencer wrote:
You can save older kext and then update to 10.6.3 and use the kext saved before.


Yes of course, but that won't be necessary for me : as I told in my previous post, I boot with arch=i386 (CoreDuo only) and I have QE/CI. I'd rather use the latest driver provided by apple (there might be a reason for the update) ...

BTW I tried genuine 10.6.2, genuine 10.6.3 and 10.6.3 with 10.6.2 kexts : no noticable change in 32 bit ...

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Tue Apr 27, 2010 11:29 am 
Offline

Joined: Tue Jan 26, 2010 8:14 am
Posts: 1
Location: Amsterdam, Netherlands
Hello,

I don't want to bother you but can you explain the way you install the DSDT.aml file?
I followed all the step from the file "Macpnt" from Sebinouse and now I've a 10,6,2 version working not to bad except restart after sleep and wifi. How do you manage wifi without atheros card? is it possible witj SL?
I don't get if the file "x60t v2" is suitable for 10,6,3 or for ,2
BTW in the MacPnt.keylayout, i think the "?" is missing.

Good job and thanks for all


Top
 Profile  
 
 Post subject: Re: Snow leopard on X60s
PostPosted: Tue Apr 27, 2010 3:27 pm 
Offline
Junior Member
Junior Member

Joined: Mon Mar 09, 2009 6:02 am
Posts: 280
Location: Paris, France
Gaurillaz wrote:
can you explain the way you install the DSDT.aml file?

You dan'i have to install anything, you just have to copy the file DSDT.aml into the directory /Extra/
Gaurillaz wrote:
I followed all the step from the file "Macpnt" from Sebinouse and now I've a 10,6,2 version working not to bad except restart after sleep and wifi. How do you manage wifi without atheros card? is it possible witj SL?
I don't get if the file "x60t v2" is suitable for 10,6,3 or for ,2

Great news ! This files (x60tv1 and x60tv2) were for 10.6.2 and they are compatible with official updates (except for several kext listed at the end of the .txt file).
There is a third version for X60t (CoreDuo 1,67gHz) with custom DSDT.aml and clean /S/L/E Folder ... you can follow the guide here (this version is compatible with 10.6.0, 1, 2 and 3 (so far) and is much more simple !)
Gaurillaz wrote:
How do you manage wifi without atheros card? is it possible witj SL?

What Wifi card do you have ? Atheros ? Intel ?
for the atheros : just add LegacyX60t.kext from the package or the AtherosFix.kext from netkas in /Extra/Extensions/ ...
for the intel : driver are in development here.
Gaurillaz wrote:
BTW in the MacPnt.keylayout, i think the "?" is missing.

Thanks for the advice, but I now use Silencer's VoodooPS2Controller.kext and I no longer need a custom Keylayout ... you can easily edit it with Ukulele if you want.

_________________
Lenovo X60t (6363-AQ8)
    Intel CoreDuo 1,67 GHz (L2400)
    3 Go / 320 Go / GMA950 / FW 400 / SD Card
    Bluetooth / Wifi AR5BXB6 / Tablet
WinXP / MacOSX 10.6.8 (DSDT patch and vanilla SLE)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 89 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 5 hours


Who is online

Users browsing this forum: Sieglinde Festkochend and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group