thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Sat Oct 25, 2014 6:13 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sat Dec 25, 2010 4:21 pm 
Offline

Joined: Fri Oct 15, 2010 1:56 pm
Posts: 1
Location: Austin, TX
I'm currently running Linux Mint 10 (Ubuntu 10.10) on my Thinkpad W500 and have encountered an annoying issue... essentially I get an intermittent hang when I attempt to restart or logout.

This problem has been made more visible as of late possibly due to my screwing around with the hybrid switcheroo configurations (see: http://asusm51ta-with-linux.blogspot.com/ if you dare) but I don't know if this is the root cause... at least I don't recall directly if this problem started only when I made the changes detailed in the switcheroo procedure.

What is odd is that when I attempt to reboot via an application (in this case the UNetBootin utility) everything seems to work fine, however, attempting to do the same via the main desktop "Menu" usually causes a hang.

Although I've done my best with the details I know the description above is still vague, however, being relatively new to Linux (at least for anything beyond a regular user) I'm not sure where to start in terms of troubleshooting...

Executing dmesg (and grep'ing for "error") gives me the following:

[ 2.321362] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 1sec aborting
[ 2.321367] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing F6D8 (len 487, WS 0, PS 4) @ 0xF719
[ 3.361344] [drm:atom_op_jump] *ERROR* atombios stuck in loop for more than 1sec aborting
[ 3.361348] [drm:atom_execute_table_locked] *ERROR* atombios stuck executing F6D8 (len 487, WS 0, PS 4) @ 0xF719

(from the output of dmesg executed after a hard restart)

Additionally it seems that I am unable to "wake" my laptop once it suspends or goes to sleep.

Any ideas?


Top
 Profile  
 
PostPosted: Tue Mar 08, 2011 9:40 pm 
Offline

Joined: Thu Nov 26, 2009 11:31 am
Posts: 3
Location: Austin, TX
I have the same problem with my T60... did you find a workaround yet?


Top
 Profile  
 
PostPosted: Wed Mar 09, 2011 7:57 am 
Offline
Freshman Member

Joined: Thu Jan 27, 2011 2:56 pm
Posts: 83
Location: Prague, Czech Republic
Please provide more specific information:
Code:
uname -a
cat /proc/cpuinfo
lspci
lsmod


Top
 Profile  
 
PostPosted: Wed Mar 09, 2011 8:36 am 
Online
Moderator
Moderator

Joined: Tue Jun 07, 2005 6:57 am
Posts: 9677
I saw this bug report the other day (in regards to suspend problem on ThinkPads). Don't know if the solution(s) have any relevance to your problem or not.

https://bugzilla.redhat.com/show_bug.cgi?id=644842

_________________
DKB


Top
 Profile  
 
PostPosted: Thu Mar 10, 2011 4:43 am 
Offline
Junior Member
Junior Member

Joined: Fri May 07, 2010 1:33 am
Posts: 457
Location: Boston, MA
I had hang problems on boot-up and shutdown on my 3000 n100 with Ubuntu.
Sometimes it wouldn't happen but more often than not it would occur several times in a row before it would NOT occur.
After various Ubuntu updates, it occurred less and less. It hasn't happened again in, oh, a few weeks now.

_________________
770E (relic not in use
3000 N100 T2080 1.73GHz
R61 773-1GU
T41 2373 7FU Pentium-M 1.6GHz Banias
X31 2672 XXM Pentium-M 1.3GHz
X60s 1702-68U L2400 1.66GHz Core Duo
Compaq Portable (suitcase size, gone)
Mac Portable (first laptop in world, Stored
Mac Laptop (Stored
Toshiba Tecra (Stored


Top
 Profile  
 
PostPosted: Mon Mar 14, 2011 3:48 pm 
Offline

Joined: Fri May 28, 2010 8:30 pm
Posts: 15
Location: Rochester, VT
I don't know if this will help, but Linux Mint 10 has been flawless with regard to suspend and resume on my X200s. I'm using this kernel (output of 'uname -a'):

Code:
Linux x200s 2.6.35-22-generic-pae #35-Ubuntu SMP Sat Oct 16 22:16:51 UTC 2010 i686 GNU/Linux


It's working so well, I've decided to not do any more updates, especially of the kernel.

I tend not to shutdown or logout, preferring to suspend instead, but the few times I've done those operations I didn't see any hangs.

It would be interesting to know which kernels have been in use on the hanging machines.

_________________
X200s (Linux Mint 13), T61 (Linux Mint 17), X60s (Linux Mint 17), T60p (Linux Mint 13), R61 (Linux Mint 13), X41 (Linux Mint 13), R50p (Linux Mint 13), A21m (Linux Mint 7), 380Z (TinyMe Linux, inactive)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group