thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Thu Apr 17, 2014 10:28 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Fri Sep 30, 2011 12:08 am 
Offline
Junior Member
Junior Member

Joined: Fri May 27, 2011 9:19 pm
Posts: 465
Location: Usually WC FL, temp ass'd to the Giant Sandbox
Is there such a thing as a Win98SE USB floppy drive driver for T20 series?

I think one of my T22s (figures it's the only 1GHz one i have and it is the only SXGA+ screen as well!) has a bad floppy controller or Ultrabay interface, because I can't seem to be able to boot a w98 startup disk to re-write the MBR.

It seeks all over creation then says file after file is missing or corrupt, but the same diskette and drive work fine in a T30.....

I was able to boot from a USB floppy drive and it read the same disk fine and i wrote the MBR (and now the machine a least boots the HDD) but then Win98 complains about the "new hardware" and can't find a driver, because there isn't one on the computer. Drive A shows up but the system can't read it. I can slide the FDD into the Ultrabay, and that became drive B: which at least read the directory, but that's a bit kludgy. I will try to copy the files from the floppy drive to a temp directory to see how that goes.

I'll also try the FDD in my known good T22, and see if it gives any problems.
I remember having trouble writing the BIOS on the 1GHz machine, because i updated all my T22 BOIS' and the 1 GHz was the only one that didn't want to work, so I may have a bad ultrabay interface in that T22.

Let me see how a HDD partition copy does later as well, that should be interesting if the interface is bad. A DVD movie play may aso test the ultrabay interface.

How hard are the FDD or ulrtrabay controllers to change out? I have a T21 and some T22s that i could swap with, if its bad and i can figure out how to change it...

_________________
760LD 9547 FUBARd; i1411 2611
T21 2647; T22 2647 4@ 900MHz, 1@ 1GHz SXGA+; T23 2647 2@ 1.13GHz, 1@ 1.2GHz SXGA+, WiFi
T30 2366-83U 1.8GHz; 5@ 2366-LU0/66U 1.9GHz; 2367-KU6 2GHz FUBARd
T61 8897-03U, 1.8GHz, SXGA+; 8898-AGM, 2.4GHz; 6463-Y64, 2.4GHz, WSXGA+; 6463-WTL, 2.1GHz, WSXGA+


Last edited by cadillacmike68 on Fri Sep 30, 2011 3:04 pm, edited 1 time in total.

Top
 Profile  
 
PostPosted: Fri Sep 30, 2011 9:09 am 
Offline
RBS10000
RBS10000

Joined: Mon Sep 18, 2006 5:17 am
Posts: 12900
Location: Mt. Cobb, PA USA
I have an official "IBM USB Portable Diskette Drive" and a matching driver-CD with P/N 22P7069.
It contains MS drivers for W98 and W95.
Put in a zip-file, it's only 141KB.
PM me with an email address.

Alternatively, for cost of postage I can send you an UB2000 floppy drive.

_________________
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Board Room for:
- LED-mods for the 15" T60/R60/R61
- SATA-mods for any T43/R52 with ATI GPU
- other Services


Top
 Profile  
 
PostPosted: Fri Sep 30, 2011 3:10 pm 
Offline
Junior Member
Junior Member

Joined: Fri May 27, 2011 9:19 pm
Posts: 465
Location: Usually WC FL, temp ass'd to the Giant Sandbox
Thanks RBS, I'll look for the zip file when i get off duty.

I have three ultrabay floppy drives (only 1 here with me) The one i have seems to work fine in two different T30s and i think it's fine in my other T22s. I'll make some checks.

I'm really thinking either a bad ultrabay interface (have not really done anything else with this 1 GHZ T22 yet) or a bad FDD controller. This T22 seems to have a dead CMOS battery as well.....

That of course would suck since this is the only 1 GHz T22 i have and i wanted to use it as a machine for old DOS / winblows games, but it didn't cost too much, so...

Interesting thing is i can boot from a USB floppy and execute DOS tasks like FDISK and recovery partition repair, etc no problem...

Things that make you go hmmmm...

_________________
760LD 9547 FUBARd; i1411 2611
T21 2647; T22 2647 4@ 900MHz, 1@ 1GHz SXGA+; T23 2647 2@ 1.13GHz, 1@ 1.2GHz SXGA+, WiFi
T30 2366-83U 1.8GHz; 5@ 2366-LU0/66U 1.9GHz; 2367-KU6 2GHz FUBARd
T61 8897-03U, 1.8GHz, SXGA+; 8898-AGM, 2.4GHz; 6463-Y64, 2.4GHz, WSXGA+; 6463-WTL, 2.1GHz, WSXGA+


Top
 Profile  
 
PostPosted: Fri Sep 30, 2011 9:56 pm 
Offline
Junior Member
Junior Member

Joined: Fri May 27, 2011 9:19 pm
Posts: 465
Location: Usually WC FL, temp ass'd to the Giant Sandbox
I also have 2 of the IBM special cables to connect to the parallel port (and 1 or 2 of the little adapters to connect to the dock port (I have 2 of the ThinkPad T2x / T30 docks), so I now can boot my T2xs and T30s in a variety of ways.

Still have not completely isolated the recalcitrant T22s issue. cloned a HDD tonite with no apparent errors. I also disk-copied the startup disk that the T22 would not read - no read errors.

On the other hand the ibm restore partition recovery diskette booted in the T22 ok and ran the IBM MBR update.

I'm at a loss, but will keep trying to isolate the problem.

_________________
760LD 9547 FUBARd; i1411 2611
T21 2647; T22 2647 4@ 900MHz, 1@ 1GHz SXGA+; T23 2647 2@ 1.13GHz, 1@ 1.2GHz SXGA+, WiFi
T30 2366-83U 1.8GHz; 5@ 2366-LU0/66U 1.9GHz; 2367-KU6 2GHz FUBARd
T61 8897-03U, 1.8GHz, SXGA+; 8898-AGM, 2.4GHz; 6463-Y64, 2.4GHz, WSXGA+; 6463-WTL, 2.1GHz, WSXGA+


Top
 Profile  
 
PostPosted: Sat Oct 01, 2011 5:22 am 
Offline
RBS10000
RBS10000

Joined: Mon Sep 18, 2006 5:17 am
Posts: 12900
Location: Mt. Cobb, PA USA
I would start with replacing the CMOS battery in that T22.
The BIOS does not function properly without it.

_________________
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Board Room for:
- LED-mods for the 15" T60/R60/R61
- SATA-mods for any T43/R52 with ATI GPU
- other Services


Top
 Profile  
 
PostPosted: Sat Oct 01, 2011 11:07 am 
Offline
Junior Member
Junior Member

Joined: Fri May 27, 2011 9:19 pm
Posts: 465
Location: Usually WC FL, temp ass'd to the Giant Sandbox
RealBlackStuff wrote:
I would start with replacing the CMOS battery in that T22.
The BIOS does not function properly without it.


I actually brought my spare CMOS batteries with me so i'll change it out.

That diskcopy i made was on one of my T30s, but it was off a W98 startup disk that the T22 would not read...

That cloning operation worked fine, i started up an old DOs game off the D drive with no issues. I'll be happy if it's just the CMOS battery.

Then i need to find the SXGA+ video driver, because the screen looks real bad with a 1024x768 on that high resolution screen.

_________________
760LD 9547 FUBARd; i1411 2611
T21 2647; T22 2647 4@ 900MHz, 1@ 1GHz SXGA+; T23 2647 2@ 1.13GHz, 1@ 1.2GHz SXGA+, WiFi
T30 2366-83U 1.8GHz; 5@ 2366-LU0/66U 1.9GHz; 2367-KU6 2GHz FUBARd
T61 8897-03U, 1.8GHz, SXGA+; 8898-AGM, 2.4GHz; 6463-Y64, 2.4GHz, WSXGA+; 6463-WTL, 2.1GHz, WSXGA+


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group