thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Sat Oct 25, 2014 11:01 am

All times are UTC - 5 hours




Post new topic Reply to topic  [ 153 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
PostPosted: Sun Apr 22, 2012 2:41 pm 
Offline

Joined: Sat Apr 21, 2012 2:02 pm
Posts: 10
Location: Bend, Oregon
I'm adding the code to the dsdt right now. I'll let you know what happens. Thanks for the help.

_________________
Lenovo X220 | Intel i5 @ 2.5GHz | 8Gb RAM | iAktos L2 | Windows 7 Professional | Ubuntu 12.04


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 3:57 pm 
Offline

Joined: Sat Apr 21, 2012 2:02 pm
Posts: 10
Location: Bend, Oregon
The USB situation is fixed. Thank you. I still can't seem to figure out the dimmer yet.

_________________
Lenovo X220 | Intel i5 @ 2.5GHz | 8Gb RAM | iAktos L2 | Windows 7 Professional | Ubuntu 12.04


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 5:59 pm 
Offline

Joined: Sat Apr 21, 2012 2:02 pm
Posts: 10
Location: Bend, Oregon
I solved the boot loader problem by simply downloading the Chameleon Preference Pane and changing the first boot from "Mac OS X" to "System Reserved" which is the Windows 7 boot manager. Windows Update works perfectly so far.

Two problems left:

1.) The dsdt file fixed the USB problem at the expense of the trackpoint. I have not found a fix for it yet.

2.) I still can't get the dimmer to work. Is there a program or kext download I can use to fix this?

_________________
Lenovo X220 | Intel i5 @ 2.5GHz | 8Gb RAM | iAktos L2 | Windows 7 Professional | Ubuntu 12.04


Top
 Profile  
 
PostPosted: Sun Apr 22, 2012 10:40 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
io anarchy oi wrote:
I solved the boot loader problem by simply downloading the Chameleon Preference Pane and changing the first boot from "Mac OS X" to "System Reserved" which is the Windows 7 boot manager. Windows Update works perfectly so far.

Nice solution.

io anarchy oi wrote:
Two problems left:

1.) The dsdt file fixed the USB problem at the expense of the trackpoint. I have not found a fix for it yet.

The trackpoint should not have anything to do with the USB fix. Make sure you are using the correct kext and use "myfix" to regenerate kext cache and fix permissions, then restart.

io anarchy oi wrote:
2.) I still can't get the dimmer to work. Is there a program or kext download I can use to fix this?

By saying "dimmer" I suppose you mean the brightness slider. Then just add the following code before Device(LNKA) in your dsdt.
Code:
Device (PNLF)
        {
            Name (_HID, EisaId ("APP0002"))
            Name (_CID, "backlight")
            Name (_UID, 0x0A)
            Name (_STA, 0x0B)
        }


Top
 Profile  
 
PostPosted: Mon Apr 23, 2012 10:35 am 
Offline

Joined: Sat Apr 21, 2012 2:02 pm
Posts: 10
Location: Bend, Oregon
I used a generic trackpoint kext that fixed the trackpoint problem. I had not downloaded the brightness slider and that was my only problem. Your dsdt fixes worked flawlessly.

Thanks so much for your help as well as patience with a hackintosh noob. Now my hack works perfectly. You're a beast!

_________________
Lenovo X220 | Intel i5 @ 2.5GHz | 8Gb RAM | iAktos L2 | Windows 7 Professional | Ubuntu 12.04


Top
 Profile  
 
PostPosted: Mon Apr 23, 2012 1:36 pm 
Offline

Joined: Sat Apr 21, 2012 2:02 pm
Posts: 10
Location: Bend, Oregon
Could you post a copy of your Keymap4Macbook preferences? I can't figure out how to map the Ampersand key correctly in order to install sleepwatcher.

_________________
Lenovo X220 | Intel i5 @ 2.5GHz | 8Gb RAM | iAktos L2 | Windows 7 Professional | Ubuntu 12.04


Top
 Profile  
 
PostPosted: Mon Apr 23, 2012 9:07 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
Here's my KeyMap4Macbook setting. Basically, I just need to remap for the backquote (`) key so that I can type ` and ~. I don't have any problem with the Ampersand key though.

Image

io anarchy oi wrote:
Could you post a copy of your Keymap4Macbook preferences? I can't figure out how to map the Ampersand key correctly in order to install sleepwatcher.


Top
 Profile  
 
PostPosted: Tue May 08, 2012 3:34 pm 
Offline

Joined: Tue May 08, 2012 3:31 pm
Posts: 11
Location: Amsterdam, Netherlands
pff i am working a week to get osx on the x220. i don't get it.

Do i have to have Snow Leopard to follow this tutorial ? because i follow the first step but its not clear...do i already need to have snow leopard on x220 ??


Top
 Profile  
 
PostPosted: Wed May 09, 2012 5:17 am 
Offline

Joined: Thu Feb 01, 2007 8:42 pm
Posts: 20
Location: Atlanta, GA
lf2 wrote:
pff i am working a week to get osx on the x220. i don't get it.

Do i have to have Snow Leopard to follow this tutorial ? because i follow the first step but its not clear...do i already need to have snow leopard on x220 ??


Yes, you need to have OS X running, either another hackintosh or in a virtual machine, in order to do this install. It doesn't have to be on the x220 first.

_________________
X61 Tablet 7767-96U | x220 4286CT


Top
 Profile  
 
PostPosted: Wed May 09, 2012 8:23 am 
Offline

Joined: Tue May 08, 2012 3:31 pm
Posts: 11
Location: Amsterdam, Netherlands
i have a pc with osx lion(vmware) but it really sucks..i want native osx native (better for performace)

first of all i dont have a external cd (x220 does not have a cd) so i am trying to do everything from a external HD (USB)

1) what did you guys change in the bios ?
2) if i follow this tutorial on my pc (osx) and create a external usb hd with all the steps i end up with a full instal for osx lion WITHOUT having any osx on the laptop now, right ?
3)some people say you have the usb to MBR to be seen but in the tutorial it stays GUID..
4)also check this, in the tutorial it says: " 2.Install Chameleon on both the partition you made and your snow partition", I don't have a snow partition so wtf ?
i can't do step 7 because i don't have any of that stuff... skipped that..

//

the first part of the tutorial sucks, its not consistent and confusing.
i followed every detail but i ended up with a clean laptop = no osx / no windows.


going to try tomorrow again.


Top
 Profile  
 
PostPosted: Thu May 10, 2012 2:32 pm 
Offline

Joined: Sat Apr 21, 2012 2:02 pm
Posts: 10
Location: Bend, Oregon
I had another question. Were you able to change your LCD screen resolution to 1366x768?

_________________
Lenovo X220 | Intel i5 @ 2.5GHz | 8Gb RAM | iAktos L2 | Windows 7 Professional | Ubuntu 12.04


Top
 Profile  
 
PostPosted: Thu May 10, 2012 9:53 pm 
Offline

Joined: Wed Apr 25, 2012 12:45 pm
Posts: 1
Location: Dhaka, Bangladesh
The obvious question is now - has anyone updated to 10.7.4? Please share your experiences.


Top
 Profile  
 
PostPosted: Fri May 11, 2012 9:08 pm 
Offline

Joined: Tue May 08, 2012 3:31 pm
Posts: 11
Location: Amsterdam, Netherlands
everything works now except the sleep mode but i will fix that soon enough.
got some simple questions..


1) do you really buy new wifi cards or do you change the bios setting alone ?

2) i got 1.28 flash bios, i download the file and use winflash and pinpoint: FvRecovery.fd to flash but it gives me an error: "Please select a correct BIOS image"...am i doing it wrong or what ?



PS: for the guys that have trouble, i had 10.7.3 LION and this tutorial has allot of files with 10.7.2 and 10.7.1 files (OSInstal especially!!)


Top
 Profile  
 
PostPosted: Sun May 13, 2012 12:04 am 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
I have updated to 10.7.4. However, AppleIntelCPUPowerManagement.kext consistently causes KP. I have tried a couple of different versions, without any luck. Now I have to use NullCPUPowerManagement.kext temporally.

One interesting thing I noticed is that, after updating to 10.7.4 the Ricoh card reader suddenly start working with this version of VoodooSDHC.kext.

So if we can find a working AppleIntelCPUPowerManagement.kext, I think we'll make x220 a 100% working hackintosh.




arshad wrote:
The obvious question is now - has anyone updated to 10.7.4? Please share your experiences.


Top
 Profile  
 
PostPosted: Sun May 13, 2012 11:04 am 
Offline

Joined: Tue May 08, 2012 3:31 pm
Posts: 11
Location: Amsterdam, Netherlands
can someone with x220 upload their latest /Extra map ? and Extra/Extensions map ?


Top
 Profile  
 
PostPosted: Sun May 13, 2012 8:49 pm 
Offline

Joined: Thu Feb 01, 2007 8:42 pm
Posts: 20
Location: Atlanta, GA
peroxide wrote:
I have updated to 10.7.4. However, AppleIntelCPUPowerManagement.kext consistently causes KP. I have tried a couple of different versions, without any luck. Now I have to use NullCPUPowerManagement.kext temporally.

One interesting thing I noticed is that, after updating to 10.7.4 the Ricoh card reader suddenly start working with this version of VoodooSDHC.kext.

So if we can find a working AppleIntelCPUPowerManagement.kext, I think we'll make x220 a 100% working hackintosh.


Did you lose the ability to put the computer to sleep after the update? I had it working in 10.7.3, but now my system just restarts when I try, both manually and when I close the lid.

_________________
X61 Tablet 7767-96U | x220 4286CT


Top
 Profile  
 
PostPosted: Mon May 14, 2012 11:40 am 
Offline

Joined: Tue May 08, 2012 3:31 pm
Posts: 11
Location: Amsterdam, Netherlands
Can someone answer the questions ???

Do I need another wifi or something like that ? Because I am trying to whitelist but the image is not accepted 1.28 ?


Top
 Profile  
 
PostPosted: Mon May 14, 2012 4:02 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
Yes, I have exactly the same scenario.


justin412 wrote:
Did you lose the ability to put the computer to sleep after the update? I had it working in 10.7.3, but now my system just restarts when I try, both manually and when I close the lid.


Top
 Profile  
 
PostPosted: Mon May 14, 2012 4:14 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
If you want to buy a Mac OSX supported wifi card to replace the original one, you have to flash the hacked bios that removes the whitelist; or the system will not boot (Laptops do not allow arbitrary wifi cards to be installed in the system).

If you want to use a USB wireless adapter instead, you don't need to worry about the bios at all.




lf2 wrote:
everything works now except the sleep mode but i will fix that soon enough.
got some simple questions..


1) do you really buy new wifi cards or do you change the bios setting alone ?

2) i got 1.28 flash bios, i download the file and use winflash and pinpoint: FvRecovery.fd to flash but it gives me an error: "Please select a correct BIOS image"...am i doing it wrong or what ?



PS: for the guys that have trouble, i had 10.7.3 LION and this tutorial has allot of files with 10.7.2 and 10.7.1 files (OSInstal especially!!)


Top
 Profile  
 
PostPosted: Mon May 14, 2012 9:18 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
I managed to get AppleIntelCPUPowerManagement.kext on 10.7.4 working, so that sleep and speed stepping work again. (I have updated my post as well.)

It requires 3 steps:
1) Patch AppleIntelCPUPowerManagement.kext.
The script and instructions can be found here.
You can also download the my patched AppleIntelCPUPowerManagement.kext, and install it in /S/L/E/
2) Add “DropSSDT=yes” to org.chameleon.Boot.plist
My org.chameleon.Boot.plist is enclosed.
3) Create or find a SSDT.aml for your processor and put it in /Extra/, along with your DSDT.aml
Here is the ssdt.aml for Intel i5-2410M.

Remove NullCPUPowerManagement.kext, if you have it installed; then fix permissions, regenerate kextcache, and restart.


justin412 wrote:

Did you lose the ability to put the computer to sleep after the update? I had it working in 10.7.3, but now my system just restarts when I try, both manually and when I close the lid.


Top
 Profile  
 
PostPosted: Tue May 15, 2012 2:04 pm 
Offline

Joined: Tue May 15, 2012 1:58 pm
Posts: 3
Location: LONDON, ENGLAND
Hello,

thanks a lot peroxide for all what you have done !!!!!!!!!!
This guide is pretty well done and I can't wait to start it, I am just waiting for a new bigger hard drive.
I am currently reviewing the steps and preparing the latest files,but I cannot find on the web a SSDT file for the 2520M.
Do you know where I can find that ?
alternatively you said "create", do you know how I can create one ?

Link found : http://tonymacx86.blogspot.co.uk/2009/1 ... ative.html

I have one more question what are klibc.dylib and uClibcxx.dylib files ?
thanks again


Top
 Profile  
 
PostPosted: Tue May 15, 2012 3:29 pm 
Offline

Joined: Tue May 15, 2012 2:43 pm
Posts: 6
Location: Los Angeles, CA
I need some help clearing a few thing up.

First, WiFi: If I use the whitelisted bios will the standard WiFi card that comes in the x220 work? If not what are some WiFi card that are compatible with the x220 (mac and windows)?

Second, My trackpad doesn't seem to recognize physical clicking of it. It only recognizes taps on the trackpad. Are there any fixes to this?

Lastly: Is EasyBCD the best option the duel boot Mac and Windows, are there any other options (EasyBCD seems a bit buggy to me).


Top
 Profile  
 
PostPosted: Tue May 15, 2012 3:35 pm 
Offline

Joined: Tue May 15, 2012 1:58 pm
Posts: 3
Location: LONDON, ENGLAND
macbookx220 wrote:
I need some help clearing a few thing up.

First, WiFi: If I use the whitelisted bios will the standard WiFi card that comes in the x220 work? If not what are some WiFi card that are compatible with the x220 (mac and windows)?


Intel wifi card are not supported on OSX. and if you use the standard wifi card change the bios is useless. ( you put a modified bios when you put a different wifi card than the original)


Top
 Profile  
 
PostPosted: Tue May 15, 2012 3:40 pm 
Offline

Joined: Tue May 15, 2012 2:43 pm
Posts: 6
Location: Los Angeles, CA
^So, what are some WiFi card that are compatible with the x220 (and mac and windows)?


Top
 Profile  
 
PostPosted: Wed May 16, 2012 9:29 am 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
I don't know exactly what they do, but they are Chameleon modules.


jamesdgb wrote:
I have one more question what are klibc.dylib and uClibcxx.dylib files ?
thanks again


Top
 Profile  
 
PostPosted: Thu May 17, 2012 4:55 pm 
Offline

Joined: Thu May 17, 2012 4:47 pm
Posts: 3
Location: Santa Monica, CA
First, let me thank for such a great tutorial! Bravo! I followed this guide and got almost everything working perfectly - except for WiFi.

I am running 10.7.3. I have X220 i7 with intel WiMax card and bluetooth.

I reflashed 1.28 whitelisted bios and replaced intel wifi module with dell dw-1515, but no wifi icon in the finder. I even tried installing HP aetheros equivalent which worked fine under win7, but again no go under OSX.

Without WiFi module I still get working bluetooth, but it would be nice to figure what's going on. I can see dell dw-1515 as a pci device.

Any ideas?


Top
 Profile  
 
PostPosted: Thu May 17, 2012 7:46 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
Generic SSDTs for i5 and i7 processors are out. Check out the following link.
https://tonymacx86.com/viewtopic.php?f=169&t=60811


peroxide wrote:
I managed to get AppleIntelCPUPowerManagement.kext on 10.7.4 working, so that sleep and speed stepping work again. (I have updated my post as well.)

It requires 3 steps:
1) Patch AppleIntelCPUPowerManagement.kext.
The script and instructions can be found here.
You can also download the my patched AppleIntelCPUPowerManagement.kext, and install it in /S/L/E/
2) Add “DropSSDT=yes” to org.chameleon.Boot.plist
My org.chameleon.Boot.plist is enclosed.
3) Create or find a SSDT.aml for your processor and put it in /Extra/, along with your DSDT.aml
Here is the ssdt.aml for Intel i5-2410M.

Remove NullCPUPowerManagement.kext, if you have it installed; then fix permissions, regenerate kextcache, and restart.




Top
 Profile  
 
PostPosted: Thu May 17, 2012 8:08 pm 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
dw-1515 should work with native driver on OSX. However, it is true that 10.7.3 sometimes fails recognize AR9280 (dw1515).
The fix is to remove
Code:
<key>OSBundleRequired</key>
<string>Network-Root</string>

from /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist, and reinstall IO80211Family.kext

There are other possibilities as well. Knowing the device ID of your dw-1515 card and related boot log (*Atheros*.kext) will be helpful.




tadhabib wrote:
First, let me thank for such a great tutorial! Bravo! I followed this guide and got almost everything working perfectly - except for WiFi.

I am running 10.7.3. I have X220 i7 with intel WiMax card and bluetooth.

I reflashed 1.28 whitelisted bios and replaced intel wifi module with dell dw-1515, but no wifi icon in the finder. I even tried installing HP aetheros equivalent which worked fine under win7, but again no go under OSX.

Without WiFi module I still get working bluetooth, but it would be nice to figure what's going on. I can see dell dw-1515 as a pci device.

Any ideas?


Top
 Profile  
 
PostPosted: Fri May 18, 2012 3:32 pm 
Offline

Joined: Tue May 15, 2012 2:43 pm
Posts: 6
Location: Los Angeles, CA
Can you maybe try to explain the sound fix, how and where to install the Kexts for the updated new sound fix?


Top
 Profile  
 
PostPosted: Sat May 19, 2012 12:05 am 
Offline

Joined: Sun Oct 02, 2011 10:41 am
Posts: 30
Location: St Paul, MN
Just download the zip file from here, and extract to get the patched AppleHDA.kext.
Then replace the stock AppleHDA.kext with the patched one.



macbookx220 wrote:
Can you maybe try to explain the sound fix, how and where to install the Kexts for the updated new sound fix?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 153 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group