thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
 The thinkpads support forum is now hosting legacy model ThinkPad driver and driver updates..
A link is provided in the MENUBAR just above for registered forum members only..

If you so wish:
Donate using PayPal

It is currently Fri Oct 31, 2014 3:02 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 12 posts ] 
Author Message
PostPosted: Fri Dec 16, 2011 2:29 pm 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
[I renamed the title to make it more accurate. The previous title was "Quick shutdown w/ no activity right after Startup".
A more complete title would be : "Windows Rehibernates Itself after resuming from hibernation, with less than 5 minutes of no Activity", but that long a title is not allowed.]

Right after I resume from hibernation on my X60s - Vista, if I don't touch the keyboard or UltraNav, it seems like there is a very short period after which the laptop just goes back into hibernation or off - like less than a minute.
My T61 does this too.

My power settings are for "20min of no activity" before going into hibernation.

Once I touch the keyboard, the "20min of no activity" does seem to then apply.

But if I go to refill my coffee cup right after bootup and come back, it's off - kind of a pain.

I can't seem to find anything in the Bios that would control this either.
It's like there's some kind of super meta hidden power manager.

Anyone have any ideas ?


Last edited by kbarb on Fri Jun 22, 2012 1:18 am, edited 4 times in total.

Top
 Profile  
 
PostPosted: Mon Dec 19, 2011 6:52 pm 
Offline
Senior Member
Senior Member

Joined: Fri Oct 13, 2006 12:48 am
Posts: 566
Location: Lake Forest, CA
If "misery loves company", I recall this irritation regularly happening with a number of my XP Thinkpads.

Once I switched to Windows 7, it's my recollection that I haven't seen the problem although I wouldn't swear to it.

Is yours XP?

Art


Top
 Profile  
 
PostPosted: Mon Dec 19, 2011 8:59 pm 
Offline
RBS10000
RBS10000

Joined: Mon Sep 18, 2006 5:17 am
Posts: 13649
Location: Mt. Cobb, PA USA
Maybe your CPU needs fresh (Arctic Silver 5) thermal paste?
It may be a case of overheating.

_________________
Lovely day for a Guinness! (The Real Black Stuff)

Check out The Board Room for:
- LED-mods for the 15" T60/R60/R61
- SATA-mods for any T43/R52 with ATI GPU
- other Services


Top
 Profile  
 
PostPosted: Tue Dec 20, 2011 7:02 pm 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
Thanks for the ideas.

well, let's see . . . . Two Thinkpads are Vista, and this also happens on a Dell desktop with XP.
I have the feeling the major manufacturers build this "feature" in, hiding it in the power management somehow.

I really doubt it has anything to do with overheating - the thing shuts down after about a minute, then when I sit down and start it up again, I won't have a single problem until the next time I put it into hibernation or turn it off, and wake it up or power it on again.

To me it seems like it has to do with some kind of inactivity timer.


Top
 Profile  
 
PostPosted: Sat May 12, 2012 5:15 pm 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
Thought I'd bump this again . . . anyone else run into this or figure it out ?

Maybe it's not built in to new Thinkpads, I don't know.
But it's annoying as hell.

You have to sit there while the thing goes through the long bootup, and then at the desktop, make sure you then hit a key to keep it from going back into hibernation.

Just this morning I answered a phone call after hitting the power on key, only to find it back in hibernation after four minutes or so because I didn't give it all the attention it likes.

I can't believe Lenovo engineered something like this, outside of user control.


Top
 Profile  
 
PostPosted: Sun May 13, 2012 3:20 am 
Offline
Senior ThinkPadder
Senior ThinkPadder

Joined: Sat Oct 29, 2005 6:20 am
Posts: 5697
Location: Israel
It's a (perhaps poorly conceived) feature in XP and the timer is 5 minutes as I recall.
http://support.microsoft.com/kb/318355

_________________
Current: X220 4291-4BG, T410 2537-R46, T60 1952-F76, T60 2007-QPG, T42 2373-F7G, X61 7673-V2V
Collectibles: X32 w/ IPS Screen, A31p w/ Ultrabay Numpad
Past: Z61t 9440-A23, T60 2623-D3U, X32 2884-M5U


Top
 Profile  
 
PostPosted: Sun May 13, 2012 1:58 pm 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
Ah, interesting.
This is the first post I've seen that might lead to something.
Actually I'm on Vista, but apparently it can have the same bug.

"You have problems after you resume a Windows Vista-based computer from sleep or from hibernation"
http://support.microsoft.com/kb/929734

Supposedly the latest service pack addresses this, and I already have that, but I haven't read or tried everything yet, so hopefully I can report back.

Thanks !


Top
 Profile  
 
PostPosted: Thu Jun 21, 2012 6:33 pm 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
dr_st - Many thanks again.

On my Vista laptop that seems to have fixed it. It was really a pain in the a r s e, so I'm glad to have finally found a way to fix the problem.
I'll now try it on an XP desktop.

I don't think I ever would have found the solution if you hadn't posted it - not an easy problem to google for.

-K


p.s. funny how my original post with "pain in the a r s e" - meant to be easy on the ears - got the rear end part (but w/o the spaces) substituted with "expletive deleted by moderators."
A rather sensitive little text bowdlerizer there. ;-)


Top
 Profile  
 
PostPosted: Fri Jun 22, 2012 1:10 am 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
I tried to fix this on an XP desktop, but to no avail.
I read at least a dozen forum and blog posts on various sites - apparently there are no fixes for this on XP.
Most of them cite the same article cited by dr_st.
Apparently the idea was, if your laptop turned on by mistake, it would prevent the thing from draining the battery entirely, leaving you with a dead battery and computer.
I wish they had made it controllable by users though instead of "MS knows best", but it was marketed as a "feature".

If someone finds a solution I'd like to know.

I'm pretty sure I solved it on Vista though.
Hopefully it won't be happening on my Win7 machine, or at least it'll be fixable.


Top
 Profile  
 
PostPosted: Tue Mar 26, 2013 5:36 pm 
Offline

Joined: Tue Mar 26, 2013 5:28 pm
Posts: 2
Location: Middleton, WI
Problem: XP goes into hibernation 5 minutes after being started or woken up if there is no real keyboard or mouse activity.

SOLVED

What DOES work is changing the power profile of the computer (I don't know why, it just does). First find out the list of all possible power profiles with this dos command entered at the C:> prompt in a dos box:
powercfg /L
Then find out what profile you are currently set to with:
powercfg /Q
Your current profile name will be on the first line.

Then create a 3-line batch file called hibernate.bat with the following lines:

c:\windows\system32\rundll32.exe powrprof.dll,SetSuspendState Hibernate
powercfg /s "Presentation"
powercfg /s "Always On"


The second powercfg line should contain your current profile name in quotes.
The first powercfg line should contain any other valid profile name.

Double click this batch file to start hibernation. The first line puts the computer into hibernation. When it wakes up the next two lines will run changing the power profile to "presentation" and then back to "Always On". Just the act of switching to one profile and then back to your usual profile will be enough for windows XP to not automatically go into hibernation 5 minutes after starting up.

This won't work if your computer enters hibernation automatically, only if the hibernation is user initiated via the batch file.

You can also create a second batch file with just the last two lines in it:
powercfg /s "Presentation"
powercfg /s "Always On"

Call it SwitchPower.bat and put it in you "Start Up" folder. Then you have also solved the problem of the computer shutting down after a restart or cold boot with no keyboard activity, too!


Top
 Profile  
 
PostPosted: Tue Mar 26, 2013 9:07 pm 
Offline

Joined: Mon Apr 02, 2007 12:39 am
Posts: 20
Location: San Francisco, CA
Hmm, interesting idea and solution.

So for the last line :
>>powercfg /s "Always On"

. . . would it work with any other chosen power state besides "Always On" ?
Because of course, I don't normally leave my computer in an Always On state.

It seems it would have to be "Always On" because if it goes to Sleep or Hibernation on its own, your batch file lines won't run.


Top
 Profile  
 
PostPosted: Wed Mar 27, 2013 7:45 am 
Offline

Joined: Tue Mar 26, 2013 5:28 pm
Posts: 2
Location: Middleton, WI
Yes, unfortunately, this only works if you put the machine to sleep manually, Which is how I've come to use my desktop machine. I do have the monitor set to turn off after 10 minutes, you just can't allow automatic hibernation. The nice thing is you can also make this work after a shut down or restart.

Another way to fix it would be to write a device driver that emulates a mouse and have it move the mouse by a pixel or two every 4 minutes. But then your computer would never go to sleep automatically either, so that's no different than above. There just doesn't seem to be a perfect solution for XP.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: xiphmont and 15 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group