thinkpads.com Support Community Forum Index Bill Morrow's thinkpads.com Open Forum - The Original Thinkpad Support Forum
Follow ThinkpadsForum on Twitter
 Support this forum, shop at newmodeus.com
 Support the forum, shop at newmodeus.com
System backups occur about 7:00 am EDT and last about 10 minutes. This will slow performance. RSS feeds have been added to the forum.
Donate if you wish to:
bill at thinkpads dot com

It is currently Fri Aug 29, 2014 11:13 pm

All times are UTC - 5 hours




Post new topic Reply to topic  [ 20 posts ] 
Author Message
 Post subject: x300 with WWAN mc8775
PostPosted: Fri Jun 20, 2008 2:20 am 
Offline

Joined: Thu Jun 19, 2008 3:45 pm
Posts: 9
Location: nes-ziona, israel
Hello all
i've got here a brand new x300 with no wwan from the factory.
so naturally i wanted a built-in HSDPA and went for getting this sierra wireless mc8775 card like reccomended around here.

i've tried to install it but got the 1804 error

the laptop currently has the newest bios version since i've ran all the updates that the system update gave me.

any ideas on how to safely bypass this issue ?
afterwards i'm planning to get the dc-unlocker to unlock it (if it's at&t / cingullar locked) - does anyone think's theres something better ?

thanks in advance for a fast reply
Tal.

_________________
Laptops and network service advisor


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jun 20, 2008 7:44 am 
Offline
Senior Member
Senior Member

Joined: Sun Dec 30, 2007 9:52 am
Posts: 616
Location: UK
Welcome to the forum - Lord-Soth.

This subject has extensively been covered in the ThinkPad T6x Series forum - Your BIOS will need to be modified to get past Lenovo's whitelist. I have successfully installed an HP hs2300/MC8775 WWAN (Unlocked) within my T60p by updating the .FL1 BIOS file. :D

DC-Unlocker is the only vendor I know of, that is available to unlock Sierra Wireless devices (and others too!). :)

_________________
T60p: T7600, UXGA, ATi FireGL V5200, 3GB RAM, 80GB SSD, BCM94322MC, BDC2.1, DVD-RAM Multi-III, W7Pro, EM770 WWAN (Voice!)
T60F: (Integrated Intel GPU) - [Another T60 FrankenPad!...Different approach]


Top
 Profile  
 
 Post subject: mc8775
PostPosted: Tue Jun 24, 2008 2:18 am 
Offline

Joined: Thu Jun 19, 2008 3:45 pm
Posts: 9
Location: nes-ziona, israel
Thanks alot for the modded bios
it helped alot in progressing with this thing.
but now i'm stuck in this situatuation :

WWAN (mc8775) card - unlocked, voice enabled - dc-unlocker
bios - zender modded bios
os : vista - with updates, no sp1

i currently have control over the wwan card (i can voice dial out or recieve calls, and send sms messages)
but when i use the data function and press the connect button in the 3g watcher (sierra's program for the card) after the connection is established i'm not able to see internet, and bytes aren't counting in or out.

also the status of the card in the network and sharing center shows it has limited connectivity and it can't get response from the dns server. (all switches are set to auto)

thanks in advance for a fast reply

_________________
Laptops and network service advisor


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 24, 2008 2:13 pm 
Offline
Sophomore Member

Joined: Wed May 02, 2007 5:38 pm
Posts: 179
Location: Jersey,UK
In Sierra's app does it show up as 'Edge','HSDPA' etc (on the top line of the virtual LCD screen) ?
Does you service provider give out 3G data enabled SIM cards or do you need to ask for one? Does you SIM card work in other data devices (3G phone etc) ?

_________________
X60 - upgraded to a X61 2.5Ghz motherboard and 8GB RAM (Windows 7 Ultimate 64 bit) 64GB SSD
X61 - 2Ghz and 4GB RAM (Windows 7 Home Premium 64 bit) 32GB SSD
USB DVD-RW DL/Blu-Ray reader


Top
 Profile  
 
 Post subject: mc8775
PostPosted: Tue Jun 24, 2008 2:28 pm 
Offline

Joined: Thu Jun 19, 2008 3:45 pm
Posts: 9
Location: nes-ziona, israel
yes to all of the above

when i take the sim card out of the laptop and put it inside my usb modem , it works , but when put inside my x300 - it works but can't get an ip address

also , i've unistalled vista and have put a clean xp pro installation and whoola ... it works smoothly under windows xp.

_________________
Laptops and network service advisor


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 24, 2008 2:36 pm 
Offline
Junior Member
Junior Member

Joined: Sun Mar 18, 2007 8:34 pm
Posts: 315
Location: Prague, Czech Republic
Be sure you have filled in correct APN in the internet profile. You can also try disabling and enabling the network adapter and then connecting, if it helps.

_________________
T60 14" SXGA+ 9c T5600 3GB X1400 4965AGN MC8780 IR BT FPR DVDRW Alps XPP


Top
 Profile  
 
 Post subject: zender
PostPosted: Tue Jun 24, 2008 2:47 pm 
Offline

Joined: Thu Jun 19, 2008 3:45 pm
Posts: 9
Location: nes-ziona, israel
i've did all that

same apn for my local network in xp and vista
vista doesn't get an ip and xp works smoothly

maybe it's because the original watcher that came with the card (cingullar's) is working on my xp

and on vista i'm using sierra's 3g watcher ?

any reccomendations for a program that works on vista ?

_________________
Laptops and network service advisor


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 24, 2008 3:31 pm 
Offline
Senior Member
Senior Member

Joined: Sun Dec 30, 2007 9:52 am
Posts: 616
Location: UK
Which version of the Sierra Wireless Watcher software do you have installed? - Version R2.4.0.1.1618 supports Vista.

_________________
T60p: T7600, UXGA, ATi FireGL V5200, 3GB RAM, 80GB SSD, BCM94322MC, BDC2.1, DVD-RAM Multi-III, W7Pro, EM770 WWAN (Voice!)
T60F: (Integrated Intel GPU) - [Another T60 FrankenPad!...Different approach]


Top
 Profile  
 
PostPosted: Wed Aug 20, 2008 6:36 pm 
Offline
Freshman Member

Joined: Fri Nov 02, 2007 5:51 pm
Posts: 111
Location: Salmiya, Kuwait
Lord-Soth wrote:
Hello all
i've got here a brand new x300 with no wwan from the factory.
so naturally i wanted a built-in HSDPA and went for getting this sierra wireless mc8775 card like reccomended around here.

i've tried to install it but got the 1804 error

the laptop currently has the newest bios version since i've ran all the updates that the system update gave me.

any ideas on how to safely bypass this issue ?
afterwards i'm planning to get the dc-unlocker to unlock it (if it's at&t / cingullar locked) - does anyone think's theres something better ?

thanks in advance for a fast reply
Tal.


Hi Tal,
from where did you buy MC8775 ?

_________________
Bashar Al-Abdulhadi


Top
 Profile  
 
 Post subject:
PostPosted: Sat Aug 23, 2008 10:07 am 
Offline
Senior Member
Senior Member

Joined: Sun Dec 30, 2007 9:52 am
Posts: 616
Location: UK
Bashar wrote:
Hi Tal,
from where did you buy MC8775 ?
Please refer to this post:link

_________________
T60p: T7600, UXGA, ATi FireGL V5200, 3GB RAM, 80GB SSD, BCM94322MC, BDC2.1, DVD-RAM Multi-III, W7Pro, EM770 WWAN (Voice!)
T60F: (Integrated Intel GPU) - [Another T60 FrankenPad!...Different approach]


Top
 Profile  
 
 Post subject:
PostPosted: Mon Sep 08, 2008 12:01 pm 
Offline

Joined: Thu Aug 14, 2008 8:36 am
Posts: 3
Location: Warsaw, Poland
@Peak2Peak:

How to install the latest drivers for HP version of MC8775 (I mean Sierra Wireless drivers)?
Thanks.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 09, 2008 7:44 am 
Offline
Senior Member
Senior Member

Joined: Sun Dec 30, 2007 9:52 am
Posts: 616
Location: UK
hornet5 wrote:
How to install the latest drivers for HP version of MC8775 (I mean Sierra Wireless drivers)?

Download the HP WWAN Broadband Wireless Drivers 2.0.16.0 from HP's website, click on the "sp36889.exe setup" icon and follow the on-screen prompts etc. - Works OK with the generic Sierra Wireless 3G Watcher Utility (R2.4.0.1.1618) under Win-XP.

_________________
T60p: T7600, UXGA, ATi FireGL V5200, 3GB RAM, 80GB SSD, BCM94322MC, BDC2.1, DVD-RAM Multi-III, W7Pro, EM770 WWAN (Voice!)
T60F: (Integrated Intel GPU) - [Another T60 FrankenPad!...Different approach]


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 09, 2008 1:54 pm 
Offline

Joined: Thu Aug 14, 2008 8:36 am
Posts: 3
Location: Warsaw, Poland
Thanks for the answer but I meant generic drivers from Sierra Wireless website, which, I think, needs some customization of Device ID (SW to HP).
But I have second question: to enable Fn+F5 working for this HP card I need to edit AcAdaptersInfo.dll file and replace the VENdor and DEVice ID which should be in form of VEN_xxxx&DEV_xxxx. Normally it can be found in Device Manager and is called Hardware IDs. But in mine I can find only: SWMUXBUS\SW_NET_0_VID_030f&PID_1e1d.
Is there any workaround in this case?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Sep 09, 2008 7:56 pm 
Offline
Senior Member
Senior Member

Joined: Sun Dec 30, 2007 9:52 am
Posts: 616
Location: UK
The Hardware ID's you found in the Device Manager SWMUXBUS\SW_NET_0_VID_030f&PID_1e1d are similar to the existing one's that appear in the AcAdaptersInfo.dll file using a Hex editor (eg VID_1199 & PID_6804 (MC8755) - VID = Vendor ID & PID = Product ID?). It maybe possible that when replace the VID's & PID's with the HP VID & PID in AcAdaptersInfo.dll & Acon.dll you might be able to see the WWAN Icon in Fn+F5 & also configure the WWAN card settings using the Access Connections utility???

If forum members have modified Access Connections with some success, please post on your procedures and experiences - thanks

_________________
T60p: T7600, UXGA, ATi FireGL V5200, 3GB RAM, 80GB SSD, BCM94322MC, BDC2.1, DVD-RAM Multi-III, W7Pro, EM770 WWAN (Voice!)
T60F: (Integrated Intel GPU) - [Another T60 FrankenPad!...Different approach]


Top
 Profile  
 
 Post subject:
PostPosted: Wed Sep 10, 2008 1:06 am 
Offline

Joined: Sat May 03, 2008 4:52 pm
Posts: 17
Location: Taipei, Taiwan
to hornet5:

1. If you're using HP's hs2300 WWAN card, you must use the HP driver or else it'll never install properly. Forget the generic driver from Sierra, apply it only after you install the HP driver to get 3G watcher working.

2. Both AcAdaptersInfo.dll AND Acon.dll need to be edited to work with non-Lenovo branded WWAN card.

3. Throw those 2 files in a HEX editor and search for 6813 (with Unicode box checked), and you'll see a set of values that goes V.I.D._.1.1.9.9.&.P.I.D._.6.8.1.3

4. Now change 1199 to 03f0 and then change 6813 to 1e1d

There should be 2 sets of these values in each of the file, so total 4 sets of values to change.

ONLY change the 1199:6813 value set, DON'T go changing all the 1199 values, that way, AC won't be able to tell what's what. Reason why we're editing this particular VID&PID is that this is the exact one for MC8775, assuming you're using HP's hs2300 WWAN (which is essentially an equivalent of MC8775 just with a different Hardware ID)

In both files these values will come in the form of 1‧1‧9‧9 and 6‧8‧1‧3, make sure when you change them you don't touch the "DOTs" in between.

AGAIN, In each file, there are 2 modifications needed (1199:6813 appears in 2 places), so total of 4 modifications for the 2 files that we are modifying.

5. After you're done, just replace them with the original files and reboot.

This is how I got the HP hs2300 to work with AC Fn+F5 before and good luck.


Last edited by perfecblue on Sun Jan 11, 2009 2:36 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Wed Dec 31, 2008 5:39 pm 
Offline

Joined: Fri Dec 19, 2008 4:18 am
Posts: 1
Location: Melbourne, Australia
perfectblue,
are you sure that you only need to modify the two files AcAdaptersInfo.dll and Acon.dll?
My Sierra Wireless MC8775 in my X300 shows the HardwareID

SWMUXBUS\SW_NET_0_VID_03f0&PID_1e1d
and I have made the following changes:

1199 to 03f0 and 6813 to 1e1d
with the result that pressing the FnF5 did not produce any result and - even the blue ThinkVantage Button did not light up anymore and pressing it had no effect.
Or do you also have to modify TpFnF5 and AcFnF5 as well??

Would you be able to send me your modified files?

Thanks.

Cheers

_________________
KCA


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 02, 2009 9:58 pm 
Offline

Joined: Sat May 03, 2008 4:52 pm
Posts: 17
Location: Taipei, Taiwan
klaus.albert:

Modifying the two .dll files had always been what needed to be done for AC to recognize MC8775.

1. If you're NOT using AC, then it's the TpFnF5.exe file that needs modifying, not the two .dll files.

2. If you ARE using AC, then the two .dll files needs to be modified and replaced with the originals, works on AC v4.52 and v5.02 so far.

I've had success on both x61 and x300 and other ppl had confirmed success on their T61 as well.


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 6:53 am 
Offline

Joined: Wed Jan 21, 2009 10:59 am
Posts: 2
Location: Bratislava, Slovakia
Maybe I'm wrong, but this isnt working with AC 5.12 on my X300
The card is recognized by AC, but any connection finish with error 58, unsupported WAN card.
Theres some other files with unicode 6813 string (VID/PID) inside, even I changed this files, its not working.


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 3:47 pm 
Offline

Joined: Fri Jan 09, 2009 1:43 am
Posts: 12
Location: Oakland, CA
I have the same problem as skdd with AC 5.12 after modifying my .dll files. Access Connections recognizes the HP MC8775 card, but it says error 58 and will not power on.

I can use the Sierra 3G watcher program, but I don't like it because it launches the watcher box every time I wake from sleep. Any ideas how to get AC to work? Maybe I need an older version (v.5.02)?


Top
 Profile  
 
PostPosted: Thu Jan 22, 2009 4:29 pm 
Offline

Joined: Wed Jan 21, 2009 10:59 am
Posts: 2
Location: Bratislava, Slovakia
is there any way to flash original firmware/IDs from 42T0931 card into HP 2300 card? I think this is the best solution fot "our" problem. :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 20 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group