Take a look at our
ThinkPads.com HOME PAGE
For those who might want to contribute to the blog, start here: Editors Alley Topic
Then contact Bill with a Private Message

X30x 7mm 2nd HDD Caddy Issues

X200/X201/X220 (including equivalent tablet models) and X300/X301 Series
Post Reply
Message
Author
schen
Moderator Emeritus
Moderator Emeritus
Posts: 1561
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

X30x 7mm 2nd HDD Caddy Issues

#1 Post by schen » Thu Feb 06, 2014 12:28 pm

Any here try one of those 2nd drive caddies found on eBay? I thought it would be pretty straight-forward like every other drive adapter I've every used. However, that's not been the case.

I put a "known good" (check using an external enclosure) Hitachi "slim" drive in it and ran across the following issues:

* Cold Boot- Gets stuck on the black, Windows flag/lights screen and doesn't finish booting despite the drive not having anything on it.

* Hot Boot- Slide in after the complete Windows load, the drive never detects, doesn't even appear to be spinning up at all.

Any thoughts? Both the "Bay" battery and the optical drive detects with no issue. Machine runs W7 Ult.
Family Daily Drivers- T450s, T430s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
ThinkPad Projects- T540p, T400, R60, Z60t
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505 :bow:

automobus
Senior Member
Senior Member
Posts: 546
Joined: Sun Jan 24, 2010 5:32 pm
Location: USA : Illinois : Chicago

Re: X30x 7mm 2nd HDD Caddy Issues

#2 Post by automobus » Thu Feb 06, 2014 12:50 pm

Welcome to the realm of double-bridge failure.

X301 contains Marvell 88SA8052. (Thank you nando4 for revealing that figure from schematic. And thank you for providing countless other hard-to-find pieces of information.)

If you are curious, you can break-open your ODD bay caddy and see what bridge it contains.

91011
Junior Member
Junior Member
Posts: 441
Joined: Sun Feb 01, 2009 6:10 pm
Location: Centennial, CO

Re: X30x 7mm 2nd HDD Caddy Issues

#3 Post by 91011 » Thu Feb 06, 2014 1:19 pm

Been a while but, as I remember, pretty much the same result as you are having.

Has lived in a drawer since.
X301 -- X201s -- X2faux1s -- X201 -- x230 -- T61 -- T60p -- T42p

schen
Moderator Emeritus
Moderator Emeritus
Posts: 1561
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

Re: X30x 7mm 2nd HDD Caddy Issues

#4 Post by schen » Thu Feb 06, 2014 6:02 pm

91011 wrote:Been a while but, as I remember, pretty much the same result as you are having.

Has lived in a drawer since.
Well, I guess it'll stay in the drawer where I put it yesterday! :roll: .....after I get that "slim" drive out of it, that is.
Family Daily Drivers- T450s, T430s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
ThinkPad Projects- T540p, T400, R60, Z60t
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505 :bow:

rkawakami
Admin
Admin
Posts: 10311
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: X30x 7mm 2nd HDD Caddy Issues

#5 Post by rkawakami » Thu Feb 06, 2014 7:13 pm

I should have one of those caddies as I'm fairly sure that I've cloned my X300 system at least once before. I'll double check on the boot and hot-swap functions. For my usage, I would have a blank 7mm drive in the Ultrabay, boot the system using a Ghost floppy and clone from the main drive. Don't think I have ever tried a hot-swap as the caddy has a mounting tab secured by a screw; not the usual eject slide and pull-tab lever.

I just checked my old emails; here's the eBay auction I purchased from: http://cgi.ebay.com/itm/300689145212 (Seller: ny-compu-tek @ $20.80 ea. 5/2013)
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

schen
Moderator Emeritus
Moderator Emeritus
Posts: 1561
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

Re: X30x 7mm 2nd HDD Caddy Issues

#6 Post by schen » Thu Feb 06, 2014 11:36 pm

rkawakami wrote:I should have one of those caddies as I'm fairly sure that I've cloned my X300 system at least once before. I'll double check on the boot and hot-swap functions. For my usage, I would have a blank 7mm drive in the Ultrabay, boot the system using a Ghost floppy and clone from the main drive. Don't think I have ever tried a hot-swap as the caddy has a mounting tab secured by a screw; not the usual eject slide and pull-tab lever.

I just checked my old emails; here's the eBay auction I purchased from: http://cgi.ebay.com/itm/300689145212
I bought what appears to be the same caddy from the same seller. However, I'm trying to use it on an X301, which I believe is the source of the issue. Apparently it works fine on the X300.
Family Daily Drivers- T450s, T430s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
ThinkPad Projects- T540p, T400, R60, Z60t
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505 :bow:

Tasurinchi
Moderator
Moderator
Posts: 2146
Joined: Mon Aug 17, 2009 8:38 am
Location: Zurich, Switzerland

Re: X30x 7mm 2nd HDD Caddy Issues

#7 Post by Tasurinchi » Fri Feb 07, 2014 3:15 am

D@rn! Should have known this before, I also ordered the same adapter :roll:
IBM Convertible 5140/L40SX/220/240/240X/2*340CSE/360PE/365XD/380D/380E/380XD/380Z/390/560E/560X/2*570/2*600/600E/750Cs/755C/760CD/760EL/760XD/770E
A20p/A22p/A31/i1600/G40/R50p/R61i/S30/SL510/2*T22/4*T4x/11*T6x/6*T40x/6*T5x0/3*W5x0/W700/3*X2x/4*X3x/3*X4x/5*X6x/3*X6xT/12*X2xx/4*X30x/Z60m/3*Z61x

rkawakami
Admin
Admin
Posts: 10311
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: X30x 7mm 2nd HDD Caddy Issues

#8 Post by rkawakami » Fri Feb 07, 2014 11:45 am

Okay, here's what I see...

On an X300, running WinXP (if it matters), on a "hot-insertion" of the caddy (Windows already running; system not in sleep mode), the 7mm disk is NOT recognized/detected. If I boot the X300 with the caddy already in place and a formatted and partitioned 7mm drive in the caddy (500GB; 4 125GB partitions), WinXP comes up normally and the drive IS detected. If I put the system in standby and remove the caddy, upon resuming, Windows will notice the drive is no longer installed. Similarly, if I put the system in standby, install the caddy, Windows DOES see the drive. I'd say that the X300 works like some of the older Thinkpads where you had to use standby to install/remove the Ultrabay device. In other words, the X300 does not seem to support a hot-swap.

I'll try the same procedure with a BLANK, unformatted drive if I can later today. I think I have another 7mm drive that hasn't been used yet.

I don't have my sole X301 set up with any OS at the moment so I can't report what happens with that system.
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

schen
Moderator Emeritus
Moderator Emeritus
Posts: 1561
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

Re: X30x 7mm 2nd HDD Caddy Issues

#9 Post by schen » Fri Feb 07, 2014 4:27 pm

Hopefully, over the weekend, I have time to take my X300 with the broken screen and hook it to an external monitor to try the tray out as well. It'd be kind of a shame to not use my one 7mm drive.
Family Daily Drivers- T450s, T430s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
ThinkPad Projects- T540p, T400, R60, Z60t
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505 :bow:

rkawakami
Admin
Admin
Posts: 10311
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: X30x 7mm 2nd HDD Caddy Issues

#10 Post by rkawakami » Mon Feb 10, 2014 3:31 am

Some more data points...

- Unformatted, unpartitioned (new, blank) drive installed in the 2nd HDD caddy and WinXP booted --> Device Manager sees the drive. Disk Management offers to initialize drive. Everything looks normal under cold boot situation.
- Hot insertion of formatted, partitioned drive still is not automatically seen AND scanning for hardware changes in Device Manager after the drive is inserted into the Ultrabay still does not recognize drive. Placing the system into and then out of standby will cause drive to be detected.
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

Tasurinchi
Moderator
Moderator
Posts: 2146
Joined: Mon Aug 17, 2009 8:38 am
Location: Zurich, Switzerland

Re: X30x 7mm 2nd HDD Caddy Issues

#11 Post by Tasurinchi » Thu Feb 20, 2014 4:36 pm

So, a review from my side (partial at least)

Got this one from Ebay: click me

Put an Hitachi Travelstar Z7K500 inside of my Windows 7 X301, drive was recognized in the BIOS, I had to manually go to the control panel/administrative tools/computer management/disk management and initialize/format the drive. After that everything worked perfect. Installed some windows updates, rebooted the computer, drive keeps working fine.

Later I'll try if the caddy works in my Debian X301.

So it looks like a happy ending for me :wink:

P.S. Haven't tried hot swap yet...
IBM Convertible 5140/L40SX/220/240/240X/2*340CSE/360PE/365XD/380D/380E/380XD/380Z/390/560E/560X/2*570/2*600/600E/750Cs/755C/760CD/760EL/760XD/770E
A20p/A22p/A31/i1600/G40/R50p/R61i/S30/SL510/2*T22/4*T4x/11*T6x/6*T40x/6*T5x0/3*W5x0/W700/3*X2x/4*X3x/3*X4x/5*X6x/3*X6xT/12*X2xx/4*X30x/Z60m/3*Z61x

schen
Moderator Emeritus
Moderator Emeritus
Posts: 1561
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

Re: X30x 7mm 2nd HDD Caddy Issues

#12 Post by schen » Thu Feb 20, 2014 5:42 pm

Tasurinchi wrote:So, a review from my side (partial at least)

Got this one from Ebay: click me

Put an Hitachi Travelstar Z7K500 inside of my Windows 7 X301, drive was recognized in the BIOS, I had to manually go to the control panel/administrative tools/computer management/disk management and initialize/format the drive. After that everything worked perfect. Installed some windows updates, rebooted the computer, drive keeps working fine.

Later I'll try if the caddy works in my Debian X301.

So it looks like a happy ending for me :wink:

P.S. Haven't tried hot swap yet...
Curiously, on my X301, I can see it in the BIOS, but it doesn't appear in the Disk Management at all so I can't initialize it.
Family Daily Drivers- T450s, T430s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
ThinkPad Projects- T540p, T400, R60, Z60t
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505 :bow:

Tasurinchi
Moderator
Moderator
Posts: 2146
Joined: Mon Aug 17, 2009 8:38 am
Location: Zurich, Switzerland

Re: X30x 7mm 2nd HDD Caddy Issues

#13 Post by Tasurinchi » Fri Feb 21, 2014 4:47 am

I've been asked if I could disassemble the caddy and look for the controller, will try do on the weekend.

I'd be glad if somebody has some pics or instructions how to properly do this. Otherwise I just grab my best screwdriver and some patience :wink:
IBM Convertible 5140/L40SX/220/240/240X/2*340CSE/360PE/365XD/380D/380E/380XD/380Z/390/560E/560X/2*570/2*600/600E/750Cs/755C/760CD/760EL/760XD/770E
A20p/A22p/A31/i1600/G40/R50p/R61i/S30/SL510/2*T22/4*T4x/11*T6x/6*T40x/6*T5x0/3*W5x0/W700/3*X2x/4*X3x/3*X4x/5*X6x/3*X6xT/12*X2xx/4*X30x/Z60m/3*Z61x

schen
Moderator Emeritus
Moderator Emeritus
Posts: 1561
Joined: Thu May 06, 2004 11:01 am
Location: Terrell, Texas

Re: X30x 7mm 2nd HDD Caddy Issues

#14 Post by schen » Fri Feb 21, 2014 3:56 pm

Well..... even worse; I just put it into my recently repaired X300 (both running Windows 7 Ultimate), and it was immediately recognized as the "D" drive! Irritating. Also, when I try to boot the X301 with the drive in the bay, Windows won't get past the black screen. :evil:

I've been asked the same thing, and I got as far as the removal of the screws. Unfortunately, there must be something else that's holding that bottom plate on there and didn't have enough time to research it right them. It might simply be 2 sided tape. I'll try to get to it this weekend.
Family Daily Drivers- T450s, T430s
Work- Sadly, the ThinkPads have gone away...... and replaced by HP ProDesk SFF drone machines :(
ThinkPad Projects- T540p, T400, R60, Z60t
Historic Retired ThinkPads- Z61m (Titanium), X20, A31p, 701c, 760XD, WorkPad C505 :bow:

Tasurinchi
Moderator
Moderator
Posts: 2146
Joined: Mon Aug 17, 2009 8:38 am
Location: Zurich, Switzerland

Re: X30x 7mm 2nd HDD Caddy Issues

#15 Post by Tasurinchi » Fri Feb 21, 2014 4:13 pm

2nd report.

Hot swap doesn't seem to work. I need to re-start Win7 in order for Windoze to recognize the hard disk again (ejecting the drive is not an issue). For the record, my X301 is a 2776-H1U with ECC 1.05 and BIOS 3.16

Debian refuses to boot in my 2nd X301, he's picky :evil: I booted with a Linux Mint usb stick and the hard disk gets recognized as well.
schen wrote: and I got as far as the removal of the screws. Unfortunately, there must be something else that's holding that bottom plate on there and didn't have enough time to research it right them
Same here, I removed the two screws, there is one more on the side, where the ejection mechanism sits. Maybe with further analysis I could get it out. But to be honest I don't feel like damaging it so I will pass this time :mrgreen: . But if I see the same model for a good price I may get it just for the sake if seeing what's inside.
IBM Convertible 5140/L40SX/220/240/240X/2*340CSE/360PE/365XD/380D/380E/380XD/380Z/390/560E/560X/2*570/2*600/600E/750Cs/755C/760CD/760EL/760XD/770E
A20p/A22p/A31/i1600/G40/R50p/R61i/S30/SL510/2*T22/4*T4x/11*T6x/6*T40x/6*T5x0/3*W5x0/W700/3*X2x/4*X3x/3*X4x/5*X6x/3*X6xT/12*X2xx/4*X30x/Z60m/3*Z61x

rkawakami
Admin
Admin
Posts: 10311
Joined: Sun Jun 04, 2006 1:26 am
Location: San Jose, CA 95120 USA
Contact:

Re: X30x 7mm 2nd HDD Caddy Issues

#16 Post by rkawakami » Fri Feb 21, 2014 9:21 pm

I'll see if I can rip into one of my adapters this weekend (bought two just in case...).
Ray Kawakami
X22 X24 X31 X41 X41T X60 X60s X61 X61s X200 X200s X300 X301 Z60m Z61t Z61p 560 560Z 600 600E 600X T21 T22 T23 T41 T60p T410 T420 T520 W500 W520 R50 A21p A22p A31 A31p
NOTE: All links to PC-Doctor software hosted by me are dead. Files removed 8/28/12 by manufacturer's demand.

Radioguy
ThinkPadder
ThinkPadder
Posts: 1124
Joined: Fri Feb 29, 2008 2:45 pm
Location: New York, New Yorrrrrk

Re: X30x 7mm 2nd HDD Caddy Issues

#17 Post by Radioguy » Tue May 12, 2015 6:16 pm

I see the trays on eBay run around $20 or so, but not all have the Serial ATA/ThinkPad sticker, and I wonder if those might have different controllers from the ones that do.

Either way, I'd love to know which is "the best" (ie: hot swappable...if any).
240, 380ED, 760C, 760CD, 760E, 760EL, 760LD, 760LD, 760XD, 760XD, A30, E520, G40, I1300, P53, R31, R40, R51, R52, R61, T20, T30, T40, T41, T42, T43, T43P, T60, T61, T400, T410, T420, T430, T460, X1C2, X30, X40, X220, X301 and on, and on, and on...

Post Reply
  • Similar Topics
    Replies
    Views
    Last post

Return to “ThinkPad X200/X201/X220 and X300/X301 Series”

Who is online

Users browsing this forum: No registered users and 76 guests